Sample Pre-Hear Lag

Why is the pre-hear function in the file-browser so laggy?

I have a < 2 msec latency with ASIO, yet there is a pretty long delay to pre-hear a sample.

I took a 4-year break from tracking, and I picked it up again only two days ago. I never really used Renoise though, I used to use MT2, which had more or less instant preview, as I remember it.

It’s really slowing me down… I don’t recognize sounds by filename, I recognize them by their sound - so it’s important to be able to key through a selection of drums really quickly.

Is there any way you could optimize this and make it faster somehow?

This is something I wondered a lot too when I moved from MT2 to Renoise, and actually am still wondering.

The sample perhaps is buffered first before sounding it? Prehear is not a DFD feature you know? Probably not the whole sample is loaded, but Renoise needs something in memory before the player engine can play something.
If you are loading MP3, aac or other stuff that requires Quicktime, this ofcourse takes longer because Quicktime is buffering it first, decoding and then transmitting it to Renoise

mmm, thought this delay would be similar to opening folders containing many files, but both .wavs & .mp3’s pre-hear almost instantly here and I’m working with a laptop rpm hd!


never a prob here. im hearing it as i click it.

just to be sure… no antivirus - app, no firewall, no chat apps and a tweaked windows?
maybe check with dpc checker if your computer can handle rt audio streams


This small “lag” was added on purpose, to avoid that the preview starts immediately and thus happens when multi selecting files or quickly navigating the selection with keyboard shortcuts. I understand that the lag may be a bit annyoing. But no lag is annoying as well in such cases.

I had the same thought. But it does seem to be a lot longer than necessary?

Something like 20-30 msec should “feel” pretty instant - or better still, set the delay to key_repeat_rate + 5 msec, so it doesn’t fire when you hold one of the cursor keys.

Or make it configurable - perhaps just as a hidden option in the config file, since most users don’t seem bothered by this. But a few of us clearly are :slight_smile: