Sample Recorder starts on anywhere even if focus is in PM

Opened Sample Recorder for recording vocals. Just to fix something, I clicked on main window, pressed the shortcut for ‘switch from PE to PM’ and pressed enter (had slots previously selected)

slots get muted

This happens:
recorder starts

Yes, the recording dialog grabs the focus. Admittedly a strange behavior, but not a bug “per se” - I believe it’s intended to work this way.
Someone correct me if I’m wrong, but isn’t this supposed to make it easier to create recordings of something “off screen” like your bass guitar?
Hopefully, you didn’t accidentally overwrite a recording! :panic:/>(For this reason, and because I use the Duplex Recorder, I always have the “create new instrument” option enabled).

in case of accidental overwriting, you should be able to keep both recordings by:

  1. saving the new recording to a file
  2. undoing to return to the old recording
  3. loading the saved recording to a new slot