Sample Sync Guessing Question

This feature has been bugging me ever since it was introduced. Before I just decided upon one setting, and stuck to it as most of my breaks were the same number of bars anyway.

This has changed with the introduction of the “guessing sync” functionality.
I typically have hundred of loops, some are 4 bars, others 8. I use the sync option but 40% of the time Renoise will not guess the right speed.

What makes it annoying is that it will often automatically put a 32 loop in 16 and I have to set it back to 32 each time I load up a different loop. why? Cant this hap-hazard guessing be disabled?

I have entire folders of loops that Renoise will systematically “guess” incorrectly, and EVERY TIME I load a loop in the same samples slot I have to set the sync back from 16 to 32.

I searched around in the prefs but didn’t see any options to disable the “guessing” while keeping the sync…

It expects that the loops are 4/4, well cut and between 80 and 180 BPM. Most of the time this should match. Probably we should use the current projects tempo as base instead of 80 and 180.
But if the whole thing just adds more work than it solves anything we should probably make it optional, yes…

Work-flow wise it’s often counter productive in my experience … A simple “guess length” on/off in the prefs would be a good solution in my opinion.

I have the same problem. every sample i load requires that i go into the sample editor and turn the looping function from forward to off. Theres no command for this and it has never done this before. any help?

Completely different problem to the one of the original poster and suggests your samples have been saved with a loop flag on. You can disable loading loop settings from preferences.

Just like the beat sync guessing. It can also be disabled in the Preferences -> Im/Export or by right clicking a sample -> Load with options…