Sample volume behavior when rendering a VSTi to a renoise instrument

Lately I’ve been making use of the render to instrument functionality to quickly convert a few of my Geist kits (this issue applies to synths as well, maybe moreso). One problem I’ve noticed is that if I sample at multiple volume levels (to capture velocity-dependent saturation/timbral qualities of a drum instrument or synth), the volume scaling behavior is not quite ideal. The volume is scaled by the VST in the original sampling process and then scaled again when I play the renoise instrument.

This results in discrete loudness jumps between velocity layers when I use the renoise instrument. Anyone have good solutions to this? I could normalize all the samples, but that’s quite a bit of manual effort, and it still isn’t quite perfect since it’s based on the maximum level and not the average power.

Go to the Sample Keyzones for the rendered instrument and disable the “Vel->Vol” button found in the lower right corner.