Samples Cutting Off

can anyone tell me how to make it so that all my drum samples in my percussion tracks play for their whole duration when triggered and not just as long as the midi ‘tells’ it to play.

Thanks :yeah:

edit => preferences => MIDI => disable “record note offs”
(this will disable note off MIDI recording for every instrument!)

maybe enabling sustain (MIDI CC#64) could also be of help.

I think guitardemon is talking about the samples, not the MIDI notes.

there’s a few options. most obvious one is using multiple tracks, or note-columns. if you don’t like that, I think there is like an NNA/note continuation mode-type setting. I’ll go check that.

remember, normally each track of a tracker is a monophonic sampler. so when a sample starts playing in a track, it will “choke” any other sample that was playing in that track (or in Renoise’s case, note column).

edit: I just noticed the word “midi” in the OP. lol. my bad. anyway I’ll leave this reply up in case someone else is having that problem.

I tried disabling ‘record note offs’ although it had no effect. :confused:

First you read this page: (Keyword: NNA -> )

Then you read this page: (Keyword:Volume Envelope)

NNA also applies to Note-Off signal.