Samples ignoring the "Quick Fade" option, resulting in Popping

Renoise Version: 3.1.0


When interrupting any note with a new note, popping occurs with fast attacking instruments, like simple chip samples.

Here’s a closeup of the rendered output where one note interrupts another.


From this waveform, it appears that a quick fade-out is resulting in overlapped notes, despite the fact that the Sample->Playback->Quick Fade option is disabled.

Steps to Reproduce:

  • Create a simple instrument using a preset like Basics->chip_square_C1.
  • Play notes successively on a single track.
  • Hear popping

Expected Result:

When the " Quick Fade" option is disabled for a sample, I would expect the note to immediately cut, and not fade out. This would eliminate the unwanted popping.

Actual Result:

The sample exhibits a quick fade-out when the note is interrupted, resulting in popping.

I’ve attached a simple project reproducing the issue.

Thank you for your time!



Your samples do not start/end on the DC line, so sound should actually improve if you enable the playback quickfade, but i’m not shure you can get this sample 100% “click” free.

Your samples do not start/end on the DC line, so sound should actually improve if you enable the playback quickfade, but i’m not shure you can get this sample 100% “click” free.

I used an NES-style sample (only positive DC) to better demonstrate the issue, but no matter what the sample or DC offset is, the same problem will be exhibited by overlapping samples creating a brief 2x volume click. Try changing the sample, you will still hear the popping. Try changing any setting you like, you will still hear popping.

Forcing a brief fadeout on all notes is really a stylistic choice, not something that should be forced on all samples without some means to disable it. This is what I believe the “Quick Fade” toggle is intended to control. Just read the tooltip, it says that it will create a quick fade In and Out, but disabling it apparently has no effect.

_ Edit: I should have mentioned that I intentionally started the sample at a non-zero offset to emphasize the problem, not to create a problem where there was none before._

I’ve attached a modified project that uses Basics->chip_square_C1. The problem remains. I don’t feel it’s quite as effective as a bug repro since it doesn’t emphasize the issue as strongly, but there you have it.

What i mean is that the “Playback Quickfade” option will force the sample to start and end at the DC line and imo it sounds much better with this ticked. If you alsosincinterpolate and keep the resampling/band limiting ticked you should get the best possible result with this sample.

You won’t get the same result as with an oscillator because of aliasing or “phase crashes” as it’s not one continuous signal line like in a real synth oscillator, but two different signal lines that does not meet on the same amplitude and phases that goes in different directions and such. Different samples give different results, i find that saw samples usually hides this unwanted sound better than for instance a sine sample because saw has a a lot more harmonic content.

Trust me, i’m a real amateur.

You may try some of the samples Danoise made a while back, which might substituteand sound better than the sample you’re using:

To make it perfect you need a synth that is able to do it perfectly, though there are many free synths out there that is not up to the task and has many of the same issues.

Try zynaddsubfx, i think it should do the job pretty good.


I appreciate that you want to help, but I only want to clearly report my issue to the developers. I already have a workaround to simulate NES behavior by using FX “GFF” and “E00” on every single note to reset the envelope without retriggering. It’s just that though, a workaround.

Short Version:

I need for new notes to not overlap with the previous note using Renoise’s built-in sampler.

Glad i could be of service, eh. :smiley:

I see now that it indeed seems to be some ovwerlapping or faulty cross fading going on there that i can’t explain why should be there.