Send Midi Clock Over Multiple Midi Outputs

Another +1 for multiple midi clock output. Could it be simple as modifying the MIDI Instrument dialog to override default clock with other? That’d be fantastic. MIDI thru cable, will give a shot :)

MIDI thru works great. For others who might stumble onto this need; route the MIDI thru of Synth 1 (slave MIDI clock out in renoise) to the MIDI IN of Synth 2.

Just wanted to say, this works awesome too in linux under jack, I have two simple midi input devices on usb that both support some type of (gate)arpeggiator, was able to connect both to the renoise clock by setting the clock output to “MIDI through” (I think it’s a JACK builtin) then in the jack connection windows connect MIDI through to both devices. Somewhere the AKAI MPKmini lost it tho but it’s probably due to my super advanced :P control code.

Thank you for this tip!
This might work for synth’s only which have a midi through port ;)

Apart from the topic I also would like to have more than four Midi-Input devices. There can’t be chained anything with Midi-Through with the USB-Devices (e.g. Launchpad, Korg Nanocontrols, etc.)

I doubt you can control even four input devices at the same time.
You can always control instruments directly using any midi controller that has not been assigned to the four main input devices.

Although, i’ll admit, for controllers this doesn’t help out.

Sorry, thread necrophilia.

I’m working with hardware synthesizers and drum machines that have to be kept in sync. A “Send MIDI Clock” checkbox in the instrument panel would really be very helpful, one “Master Clock Output” doesn’t cut it.

MIDI thru introduces lag, and isn’t present for USB MIDI devices (standard nowadays). MIDI Yoke is discontinued. Are there any other workarounds?


Fairly new to Renoise and was surprised to see only one clock output. Am on OSX so managed to work around it using the free MIDI Patchbay -

Can create a virtual port in MIDI Patchbay, route clock to that and then from there to all physical out ports and devices.


Thanks for this tip! We’re near the end of 2020 and still no solution within Renoise, but happy to see this workaround!