Serious bug in system dialog handlng

Renoise very often (and I check this on second computer) freeze when plugin needs to open system dialog window (like file open/save dialog). It works, but when you try to do something more (like change task to find file or trying to create folder etc.) it freezes. Is unable to write anything in dialog window. It’s similar with all system dialogs - when plugin needs to be registered and uses system window for that - good luck with copying serial from email client and paste into plugin.

Sounds familiar. Do you use a SSD for loading/saving your plugin things?

Yes. I have in fact a lot of drives.

Could be a bad controller. Some SSDs have problems when lots of save/delete processes are going on. At the beginning they work fine, after a while (some weeks/months) they get bad sectors. This mostly happens with MBR intialized SSDs. Bad or damaged MBR sectors can cause such problems like yours. Bad MBR can happen, when a lot of saving/deleting processes are going on. Older generation SSDs are MBR initialized and have problems with a lot of such processes. The newer SSD generations are GPT initialized and work way better for such processes.
But there’s a little trick, how you easily can repair bad MBRs. Shut down the computer, open it, unplug the data cable from the SSD, but leave the power cable connected. Then start your computer. It doesn’t find the disk now, because the data cable is not connected, but that’s fine. Now leave it running in this state for 30 mins. then shut down the computer again, re-connect the data cable and start the computer. Now it should be running fine again.

Why is this: MBR SSDs have a small hidden “self repair” feature. If the disk is running without data cable connected, the SSD tries to repair its bad MBR. This needs around 30 mins. In most cases this should work. If this doesn’t work for you, then it may be another issue.

You also can try this with your system ssd. Mabe the issue is there instead.

Important note: never, i say it again, never defrag a SSD. This can damage it.

Man, it’s not some controller or system-side problem. I can’t access file dialog on two different computers in Renoise. I am sort of computer freak and really know when there is a disk problem, drive problem and when it’s program problem. I can open file dialogs in any program and they’re not freeze. Never! I don’t even use drop menu for choosing path, mostly just type everything, because that’s faster for me. And I can’t type anything because dialog is freezing and after I switch to another task, I can’t even return to Renoise proper - dialog is hide somewhere and only win+tab give me access to it. Only strange series of alt+tab or win+tab can un-freeze Renoise.

Ok, then it’s another issue. Had similar problems when loading/saving things. For me this helped.

Hrm, cant replicate, so couple things that might help:

What OS are you using, is there a syslog or event viewer item that appears near the time of the problem?
Run “Process Explorer” or “SAR” and look at “Filehandles” when you replicate the issue.
Perhaps try with your antivirus diabled if you are willing to do so.

Hth

Ok, I have eM Client, Opera and Messenger running plus probably few other tools that system use.
That is not improtant.

  1. Start Renoise…
  2. Open Vital plugin.
  3. Click on Import Bank (standard windows dialog appears)
  4. Cancel (you don’t want to import any bank anyway)

That works.

But now try something else.

  1. Start Renoise
  2. Open Vital plugin
  3. Click on Import Bank
  4. Leave that dialog window opened and click ALT+Tab and switch to your web browser (because, for example, you want to read “how to install bank” again)
  5. Click ALT+Tab and return to Renoise.
  6. … where is dialog? Try to find your dialog and look how Renoise behave (total freeze, not possible to bring dialog to front).

EDIT: IMPORTANT!

This bug is only when you have classic old-style ALT+TAB enabled in your system

In normal, standard Windows configuration there is no problem.

Unfortunately, some people really like old-style clean and small alt+tab icon-style look.

And, what is more important, in classic ALT+TAB enabled, I see Hybrid synth after project reload. In a strange way, somewhere in left top corner, but see it. In standard config, after project reload, Hybrid shows only black window (it works few versions of Renoise back without any problem, but now is too late and problem will not be fixed).

I tried your way. I made the registry entry for the old Alt+Tab style and followed your instructions. Can’t replicate here on my Win11. Works like a charm here. Maybe it’s a problem between Renoise and Win10 only and doesn’t happen on W11.

Do you restarted your pc after registry change? And yes, I have win10.

Yes, i did.

excellent synths you did…

Problem in ladder filter (alpha + 1)…not tried the v2

Too present noise in V1

alpha + 1 was a better gui

But otherwise…Beast synth

IMO

@Mastercode: So it may be a problem with win10 only then.
@Acceleration of T-ger: ???

Mastrcode is a serious VSTI coder

macos versions then!

TLDR But maybe it would help if you deactivate sandboxing (and then restart Renoise)?

This is a little annoying, because apparently I can access Hybrid3 window (after project reload) ONLY when I have old style alt+tab enabled. But then I have problems with dialog windows. But when I switch to “modern” alt+tab - everything works, but I can’t access Hybrid synth anymore. Sad that Renoise programmers don’t know what changes from 3.2.2 to 3.4.2 so it stops working.

I figure out how to bypass this problem, a small workaround - win+tab, then select dialog box and it starts working. So problem “solved”, kind of.

It really seems that it’s a Win10 issue. I can open all Air Music Tech VSTs (incl. Hybrid3) without any issues in Renoise on W11. No matter if i use classic or modern ALT+Tab.

Nooo, I can open them too. But save your project (with Hybrid3) and re-open it, and THEN try to access your saved Hybrid3. :slight_smile:

OK, after reloading the saved project i also get a black Hybrid3 VST window in Renoise. I also tried it in my other DAWs, there all is re-loading fine after saving. So i now can confirm, it’s not a Windows related problem. It seems there’s an issue with Renoise and the Graphics API of the plugin.

The AP 1 uses a kind of state variable filter. There’re still some resonaces, even if the resonance control is turned to 0 which can sound like there’s some noise present. That’s the way a state variable filter works. But i’m planning an update with a better, noise-free filter with some more filter types like a Moog filter, Korg stye filter, Sallen Key, Transistor Ladder, etc.

Maybe i’ll also add some more effects like a phaser, chorus, Flanger, a compressor, maybe a new delay unit with some more features and a better reverb.