Set to 12 cores but only one is used


(whisp) #1

Hi!

I’ve recently bought a new PC with an i7-8700k. It has 6 cores, 12 logical processors, which show as 12 cores/CPUs in Renoise.

The thing is: Songs i created with my 8 years old PC don’t run anymore on the new rig, due to the engine stopping “because it used too much CPU for quite a long time.”

When i check the CPU usage in the task-manager parallely, it stays at around 15% total, compared to Renoise’s 90%+ usage.

Obviously Renoise fails to use the cores for some reason.

I’ve tried it with different amount of cores set in Renoise, it didn’t help. And disabled overload prevention, and got no more message, but the song started stuttering at 99.9% usage.

I don’t know what else i could try. Any help is appreciated.

Kind regards,
Mario


(TheCytha) #2

Mario!

Check out the thread here which might have some answers (basically, make sure computer is in “performance” mode and is not throttling).

Good luck!
=T3=


(whisp) #3

Hey T3, thanks a lot for your input!

Unfortunately, following the instructions on http://isboxer.com/wiki/HOWTO:Disable_CPU_Throttling_in_Windows didn’t solve the problem for me.

Also, tested a bit with the most demanding VST instrument in the song. On the Spectrasonics homepage they state, that one instance of their VST will use only one CPU (i’m not sure if that’s usual for any VST), so i created one instrument per voice. But neither did this change anything: It seems that the same CPU gets assigned to all instruments.


(whisp) #4

Also, installing the latest chipset-drivers and reinstalling Renoise (3.11) didn’t help.


(Raul (ulneiz)) #5

What model of motherboard do you have?


(whisp) #6

It’s an MSI Z370 “Krait Gaming”


(Raul (ulneiz)) #7

I guess you’ll be using the BIOS version 7B46v10.zip
https://www.msi.com/Motherboard/support/Z370-KRAIT-GAMING#support-cpu

You could try to update to the latest available BIOS (7B46v17): https://www.msi.com/Motherboard/support/Z370-KRAIT-GAMING#down-bios

The firmware of the motherboard is the one that contains the necessary instructions to be understood with the CPU… I guess you’re using Windows 10 x64 and you’ve already tried practically everything.


(whisp) #8

Thanks Raul! Yes, i didn’t update the BIOS, yet, and the PC is already a couple of months old, the latest BIOS version is surely newer than the installed one.

I will give it a try and will post the result here (if my PC still boots afterwards ;))


(whisp) #9

BIOS updated, PC still works. :slight_smile: But Renoise still only gets one CPU’s power…

Double-checked the BIOS settings after updating and didn’t find anything that i’d assume would keep Renoise from using all cores. Then again many of the CPU related advanced settings in the BIOS - and there are a lot - i do not really understand. The ACPI settings are sparse (e.g. i cannot configure anything about processor parking anywhere in the BIOS) and in the CPU settings it is set to use all cores (which seems to work fine, at least the Task-Manager shows activity in all CPU’s, but not from Renoise).


(Raul (ulneiz)) #10

If the conclusion is that the other programs that handle multiple threads of CPU work correctly (use all the cores), but Renoise only uses one, is that something happens with Renoise and that generation of CPUs (some incompatibility). You just have to compare the behavior with other software under the same operating system. If another software works well with all the cores and Renoise only uses one always, there you have the problem.

I assume that you use the view of logical processors in the Task Manager and you use the Resource Monitor to see the changes in the use of multiple threads …

image

image
Play a simple song, with 8% of CPU use in the Renoise marker.

It would be nice if you copied some screenshots…


(stoiximan) #11

Could this be audio driver related?Try usind asio and direct audio and see how things come up.Also download and older version of Renoise and see if it has the same problem.Update directx.


(whisp) #12

@stoiximan Thank you! Just downloaded, installed and configured Asio4All, but no change.

However, looking to the CPU stats with Performance Monitor, with only Renoise selected, there is indeed activity on multiple cores. Thanks Raul!

Here a screenshot as suggested:

2019-03-29_15h02_15

In the “song” used for the screenshot i’m playing one track, playing the notes rotating between 4 Omnisphere-instruments, each with the “Analogue Drama” patch (very expensive patch) and each limited to 2 voices (default is 8).

On my old PC i used one Omnisphere-instrument with this patch, and 8 voices and the engine didn’t stop. My attempt to explain: The old PC was an I5, i’m not sure how many cores it had, if i am not mistaken there were 4, and no logical processors. And the CPU was overclocked. And thus one core of my old PC was more capable than one of the logical CPUs of my new rig.

What contradicts either my above explanation or my earlier assumption that an instrument is a VST instance: Even though i’m using 4 Omnisphere-instruments, the load is primarely on CPU 9 (screenshot). Do i need to instantiate the VST in a different way? Like duplicating the DLL instead of creating multiple instruments from the same VST? I will give this a try.

(Side note: Tested the core usage with CPU Z stress test. All ran on maximum.)


(Zer0 Fly) #13

I know of 2 other things breaking renoise multicore support.

One ist renoise can only spread load if there are different tracks. One track per core, one instrument per track - seems to be the optimal way of setting up things.

The tracks seem to be calculated in the same core, if parameters in them are interconnected i.e. with hydras, signal followers etc. These can be moved to send channels to make the underlying tracks work multicore again.

Yeah and it could be possible that a VST will establish some sort of main process on their first instance load, and all following instances will feed it with data to make sounds. Many VSTs use this feature to actually make better multicore action, but I could very well imagine that something went wrong™ and the process is somehow nailed to a single cpu, by renoise or by configuration of the VST or elsewhere. Have you tried sandboxing the VST?


(Raul (ulneiz)) #14

As it seems in your screenshot, you just not use a large percentage of each thread because Renoise does not need it at that time. In fact, you are using up to 9 threads at a time at the time of screen capture.

It seems normal behavior.


(whisp) #15

@OopsIFly Awesome, thanks for that Info. This works!

I’ve just spread the 4 Instruments on 4 tracks (and even increased the voices count per instrument to 4) and voila, load is split up and the engine doesn’t stop anymore!

2019-03-29_16h01_37

Thanks all for the help, it’s much appreciated!


(TheCytha) #16

So glad you got this sussed out! I had a similar issue on my old computer but it blew up before I ever could fix it (so, I guess, my fix was to buy an entirely new comp lol).

Zer0fly - thanks for the info. Bookmarking for inevitable future problems™ :slight_smile:


(system) closed #17

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.