Shortcuts with ALT key acting weird

every shortcut in 3.2 that uses the ALT key behaves weird here, some won’t work at all (alt + a,y,q,t) some will only react after a certain time. Assigning new shortcuts that use ALT is also difficult. Anyone who can confirm this?

(windows 10)

Alt+T in the pattern editor seems to work without problems here (windows 10), will try some others.

@weizenkeim. Are you using any strange tools? To discard, make sure you disable all your tools. Try again. And if the problem persists, report it again.

It is also possible that your physical keyboard causes the fault. This can be common, when keyboards start to fail.

Try to discard things by doing several tests. Try another software program, see if you have problems with the same commands.

I have tried all those commands and I have no problem with R3.2.0 & WIN10.

I made a clean install with no tools and factory settings. Same thing. Think I found the problem though. I use an old apple keyboard on my win pc and have switched alt and win keys in the registry. so that might cause it.
Strangely it works in every other software including renoise 3.1.1
…new keyboard then?? :frowning:

I have the same, or similar, problem here on my laptop (winx64).

Block transpose, cut, copy and paste (alt-f1/f2/f3/f4/f5) didn’t work. I thought they were changed first, since ctrl-c/x/v works for copying a selection, but the shortcuts are set properly with alt in the keys preferences.

In my case, I suspect there is some conflict with an nvidia driver/software that tries to invoke some “photo mode” (whatever) when these shortcuts were pressed. Renoise 3.2 shortcuts temporarily worked during the actual update of this driver. With 3.1 I just didn’t care about the small screen overlay from nvidia when I pressed alt-f3, but now it seems to break the Renoise shortcuts :frowning: Could this be the case on your end too?

I’m trying to find a way to disable the nvidia stuff, but can’t find it atm.

I uninstalled geforce nvidia experience and now it works for me. Seems to be bloatware anyways.

For reference, if anyone would be keen on reading about it:

I too have nvidia hardware. But in my case the problem really were the reassigned apple & alt keys.
I just reset the registry and all works like intended. Damn… I like the keyboard but this way I will constatntly mix up alt and OS-key again.

This started to happen to me for some days now in win10.Control+z does not work and the A key does not write not offs.I suspect other keys have problems too.It happened suddenly and I haven’t messed with Renoise settings

Has anyone figured this out? Any official word yet? I’m using an Apple keyboard on Windows 10 (1903). I used SharpKeys to remap the layout to Windows (i.e left alt/right alt/windows keys/f11-13 etc.) and everything worked perfectly on Renoise 3.1. So far I’ve tried:

Running as Administrator
Disabling/tweaking the HiDPI options in properties
Updating Windows 10
Removing unnecessary startup programs.

No nVidia card in my studio machine, so no nVidia bloatware to uninstall. At this point, I’ve gone back to Renoise 3.1, as not having the shortcuts on my keyboard is slowing my workflow down too much. I hope this gets addressed and fixed ASAP, as it’s obviously an issue with 3.2, since 3.1 works exactly how it should.

Just to understand the problem. Does this always happen, after starting Renoise? Or is it something that happens suddenly (maybe caused by something that has happened before)?

Can you detail what keyboard model you have?

Apple don’t sell it anymore, but it’s one of these:

Had it for about 5 years with no issues. This problem only happens in Renoise 3.2. For instance, if I load up file explorer and switch to it, I can press Alt+F and open the File menu. Switching back to Renoise, alt keys no longer work. And yes, every time I load Renoise 3.2 it behaves like this.

Do you have any other physical keyboard to try? If you try another keyboard and it doesn’t happen, everything seems to point out that Apple’s keyboard doesn’t get along with Renoise. It seems strange this.

ok, so I am not the only one. something must have happened to the way renoise grabs its keystrokes. I am not hoping for a quick solution because it seems to be such a niche problem, so I just switched to a new pc keyboard. It was overdue anyway.

just in case: this is the problem
– in win 10 I switched the alt key and the apple key on my keyboard with regedit, in R3.2 I then cannot assign or even enter the alt key, doing an arpeggio on ctrl+shift+apple will create an entry with altctrlshift, holding alt and cursor in the instrument panel will at some point (after some seconds) move the instrument cursor —

Did your new keyboard fix the issue then? If it did, I’ll just buy a new keyboard, since I’m long overdue also.

yes, I think it has something to do with the menu opening abilities of the respective keys. It always felt like the alt (system) key would work after some time, as if it it first had to show and hide some menu. on a regular qwerty/z keyboard for pc everything works fine

Good to know. Thanks

Got my new keyboard, and the issues I had with the Apple keyboard have now gone.