Shrunken VST3 GUIs

I have a very irritating problem that renders my VST3 plugins (and thus making music) impossible.

Example: (image link)
Large black window with the GUI about 1/3 the original size in the bottom left corner.
More irritatingly, the clickable areas are that of the original, so can’t operate the small (and unreadable) GUI as well.

It was the same at some other VST3s where it miraculously fixed itself without any updates, but for some it stays like this.

What’s the solution?
Thanks in advance!

What version of Renoise are you running, 3.3.2 was recently released, what OS are you using, which VST(I)'s are you experiencing this with? Does it happen all the time for the same plugin? Any scaling going on in the gui preferences, does changing settings here help?

I am running Vital (version 1.0.4) here in windows 10 without any problems.

Fyi; in Vital you can click the V shaped logo top left of the gui to change the size of the plugin, try changing these to see if this helps/resets the gui?

thx for the reply.

using 3.3.2, win 10. i had the same issue with TrackSpacer, fixed overnight, but with Vital it stays like that, all the time. There were other plugins with the same issue in renoise, can’t remember which ones (minor ones, tried them, “ah, not handled well. great!” and deleted them). couldn’t find GUI scaling preferences.

top left options: yeah that’s my problem, as the buttons in the window are clickable in the proper places BUT the gui is small (mismatch between visible button and its clickable position), i can not click it, unless i bullseye the supposed position of the button :smiley: :smiley: EDIT: managed to do it. to no avail. now i can enjoy the borked, misaligned VSTi window in bigger size :slight_smile:

image

Check where it says ‘user interface scaling’, I have it on 125%, perhaps you can try different settings here? Running out of ideas, re-installation? Good luck :sunglasses:

Just try one more thing:

  1. Go to Windows 10 and make sure to use 100% scaling.
  2. Restart the computer.
  3. Check if you are still having trouble scaling your VST instruments in Renoise.

For monitors with large resolutions, instead of using general screen scaling, I use the accessibility options to increase the text size. I settle for the smallest icons but the largest text.

Really, Windows 10 scaling is a disaster, and it seems to affect Renoise as well. I have never been comfortable with scaling above 100% in Windows 10, because it returns blurry windows of programs, and other problems and with Renoise he doesn’t get along very well either…

thanks for the replies, gotta try them out, although since only about 2% of VTS3s have this issue, i don’t think this global solution is very feasible, especially given the fact that the current layout of the entire DAW is very comfortable as it is now.

fyi nope, nothing helped. dunno if it’s renoise-specific or plugin-specific.

I’m having the same problem with some vst3:s

Vital
All Arturia V plugins (V Collection 5) - edit: works when reopening the GUI

The top 50% of the GUI is black and plugins are unusable. I’m getting a feeling that it has something to do with JUCE, but that’s probably totally wrong.

I don’t have any issues with the V collection 8 on Win10, never tried earlier versions

Izotope Neutron 3 also has graphical glitches. It’s barely usable.

I have Neutron 3 Advanced (VST3) and never had an issue with that… Could it be your graphics card or something?

It works fine in Studio One though.

I have dual monitors on different resolutions/scaling. Perhaps it’s confusing Renoise.

I just have a widescreen… maybe try disconnect a monitor and see what happen

ffx taught me the workaround now. I will run all obnoxious plugins without scaling, at 100%. That’ll do for now!

LOL just told you that you can disable renoise per plugin scaling. That said I really wonder why scaling works correctly in studio one, as you said, but not in renoise. So in studio one, the plug-in is correctly upscaled even without an option, automatically? Doesn’t this then mean that renoise does it wrong?

S1 have had occasional issues with some effects/synths too, but I haven’t stumbled upon it recently. Not sure if it’s fixes from presonus or fixes from the plugin vendors that have remedied such situations.