Slow Startup

Renoise seems to need a lot of time initializing the waves plugins-shell on startup, i think about 40 seconds.
it didn’t use to be like this in the early betas of 1.9 i think. anyone else expierencing this behaviour?

You may want to try to defrag you HD. Also when starting the OS, wait a bit until its fully “up and running” before starting Renoise - wait until the HD access from the OS calmed down a bit.

Maybe a little offtopic, but: Is that a normal behaviour, that all waveshells (mercury, diamond, ect.) are getting re-scanned by renoise at startup? Atleast it happens here every time, which indeed slows down the startup a tiny bit.

i defragmented my disk, but it didn’t help. it actually takes about 1,5 minutes to load renoise after a fresh windows start because of the eaves package.

and i still have 1.8 installed, which needs the same amount of time to start. so it’s not a 1.9 issue after all… but the weird thing is that it didn’t use to be like this before.

and now i just remembered:
a while back i had to set my system disk c to “compress files to save disk space”… that was probably stupid to do…! i guess that’s the reason for the slow loading, so i’m reversing that process now :)

hm, nope that didn’t have any effect, after all.
any other ideas about what causes this behaviour?
is there a file i could send you taktik, that is relevant for looking into this matter? an .ini or something?

thanks for the reply bantai.
you were right… i disabled the vst-folder, restarted the computer, launched renoise, and … it still needs 1-2 minutes to load. except now it hangs during “searching for new vst plugins” instead of “loading Waves 5.2 shell” like before.

i looked into the settings folder, where the CachedVsts.xml file is located, and i see that its size is almost 900kb big. could this be right?

would it be an idea to maybe erase both the content in this file and in the cachedfailedvst.xml to achieve a fresh memory?

thanks for the response once again.

well, when i updated my xp to sp2 about a month ago (i had to…!)
i was afraid i would lose the stability of my firewire setup, but it seems to work as before.

however, i now came to think of another couple of weird things about my system, i’m not sure, but it may have changed to this after the sp2 update:

  • macromedia flash needs 30-40 seconds to start (was not like this before)
  • swift 3D (another gfx app) also needs lots of time to start up¨
  • sometimes when i record realtime-keyboarding of vsti’s in Renoise,
    the sound starts to stutter.
    … and this last thing i understand could be an fw-issue, but it shouldn’t have something to do with Flash and Swift

… i have tried to reinstall all of these, but without success.
but a part from all this, my system is running fantasticly. it’s like there’s a TORN somewhere, lagging certain software. luckily i am not running internet on my music computer, so there’s no virus or anything

i will try to search the net for other firewire-SP2 related stuff to see if it could be that.

hey. i have now updated my xp SP2 with a firewire-fix patch, but it didn’t resolve anything.

i noticed also another ‘bug’ that often occurs;

  • when closing a song, or renoise itself, that uses energyXT i get the “Fatal Error” message in Renoise. but it doesn’t seem to do any harm, as i can continue working without restarting renoise.

  • also, sometimes when i close renoise, the app hangs and i have to close it down through taskmanager.

i wonder if all these issues i have is connected somehow.

i finally found the reason why my system acted weird, so i thought i’d post here if anyone else should experience similar problems.

why renoise needs about a minute to start, after a fresh computer
startup: the EZ drummer plugin (with 6 expansion kits). when disabling the ez drummer folder in renoise vst settings, it worked fine the next time. i guess it’s just a demanding plug, probably because of all the thousands of files it needs to activate.

why flash, swift 3d and some other GFX apps needed over a minute to start: i had WAAAAY to many fonts innstalled in windows (over 3000) and when deactivating these it all worked perfectly. fonts are incredibly
memory unfriendly.

so yeah, i am all happy now :)