Sluggish Animation/UI in M1 Big Sur (3.4.1)

I’ve installed the latest 3.4.1 version of Renoise running natively on my M1. The overall animation of the meters and scopes are extremely slow, feels like 15 fps.

The 3.3.1 version of renoise runs perfect on this machine, no slowdown or sluggishness at all.

That’s weird, it should run smoothly esp. on m1 Macs. Do you have the metal rendering option enabled? Maybe Monterey is required then, don’t know

Which M1 based Mac is this exactly?

As ffx said, you could try enabling or disabling the Metal based GFX rendering option in Renoise’s Preferences, GUI section to test if this is the problem.

hi! it’s a 2020 Macbook Air M1 with the latest version of Big Sur. I’ve enabled/disabled all the options in the Renoise Prefs and tried different combos, nothing is working out. I’ve even tried changing color profiles. It’s really strange because 3.3 works fine :frowning:

Weird. Does it work fine when running Renoise with Rosetta (starting the Intel version instead of the ARM version)?

To start the Intel version on a M1 based Mac:

  • Select the Renoise.app in the Finder.
  • From the File menu in the menu bar, choose Get Info.
  • Enable the “Open using Rosetta.” option
  • Double click Renoise.app to start it

This is not meant as a workaround, but to figure out what the problem could be.

i’ve tried using low resolution, rosetta, non-rosetta with low resolution, tried a bunch of different color profiles, etc… no luck :frowning: it’s not really a huge deal for me, maybe it will work when I upgrade to monterey? if there’s anything that I can provide that can help you, let me know. i’m cool runnings with 3.3.2 for now.

I have the same problem with 3.4.1. Mac m1 Ultra running Monteray. Reverting to 3.3.2

That’s weird. I am running Macbook Air M1 2020, latest Monterey and Renoise 3.4.2 on either built-in display or 4K external display and it works very fast. I think it works that way since version 3.4.0.

I think if you disabled the metal renderer in the prefs, it should behave like every prior Renoise version. So there should be no need to revert to an older version, at least AFAIK. It is weird that it seems to slowdown on your m1 system.

So let’s check some points:

  • Do you have the monitor’s color profile enabled? What happens after swithcing to the sRGB color profile? You might have to restart Renoise at every change first.
  • Please check your activity monitor: Sort the table by cpu usage, is there any app constantly hogging the cpu with 100% or even more? I ask this, because I have this bug regularly on my Monterey M1 pro mac. WindowsServer then is using more than 100% constantly. Only a relogin will fix this.
  • What happens if you load a song which uses no Sandbox / no Intel plugin at all? (Disable sandboxing in prefs, restart Renoise, then check activity monitor for “Renoise”. There should be only one single process running)
1 Like

Thanks so much for your reply FFX. I tried all the above. Restarting Renoise/ My Computer on multiple occasions.

My problem is resolved when I turn off 'Enable Retina HiDPI Display Support. But obviously, it makes the screen look terrible. That is where the problem is coming from anyways.

Interestingly the problem gets worse and worse the more you scale the interface. Turning off Mouse Warping also helps the Problem

Hm well then I also have no idea what is going on here. Hope you will find a solution!

1 Like