So, I Tried To Use Renoise And Logic, But....

Not only did my rewire with renoise as slave to logic not work, Logic will not open at all, no matter what else is happening. Bus Failure!?!?!?!?!? Some internet research has led me to believe that renoise reallocated something pertaining to rewire, and now logic is tripping because it can’t find it. Can any of the saavys on this effin help a brother out?!?!?!?!?! Cheers!

Not personally done anything with Rewire but don’t you have to open the Master application first? If you are trying to open a Master after a Slave I would expect some kind of problems. If Logic wont open when set as Master, and you are opening it before Renoise, then it can have nothing to do with Renoise can it.

If you open Renoise first, it will always operate as a master and other slave applications are best opened by inserting a ReWire device and choose the ReWire application from the dropdown there.

If you open Renoise second, it offers to open as a slave.

I have used rewire many times on other applications, and I opened my apps in the proper order; this is something that has totally screwed up logic, whether or not I am trying to use it rewire…it won’t open at all. I am getting bus failures. The error report seems to be pointing toward the rewire engine being the reason logic won’t open. Either way, my one attempt at using rewire was done properly. This also happened with Protools (though I never tried to use them together). The only way that got fixed was moving my rewire plug in to the unused folder. I currenty can’t use PT Rewire on anything. Logic, however, doesn’t handle rewire via plug-in…so I am lost as to what happened when I installed renoise. Please help me.

One other thing you can try is to uninstall Renoise, then remove existing traces of other rewire engines tracking the sources down in the registry… (Taktik explained this somewhere not long ago , but i can’t find the thread, i guess we should have made that one a sticky…) and if you uninstalled the other ReWire engines, reinstall Renoise and try again.

Some hosts use another ReWire dll version, i have no idea what that’s good for, but not all are compatible with the Renoise variant.

Thank you very much for the help…I’m tracking down this thread as we speak…we’ll see what happens

Or you could try a program which gets rid of all the traces automigically. I use ‘Your Uninstaller’. Cheesy name I know, but gets the job done and is actually a very good proggy for apps that don’t uninstall themselves properly (i.e. - all of them). :)

Free 30 day unrestricted trial.

Uninstalling, reinstalling is not needed on OSX.

To use Renoise as ReWire slave, please follow this small guide:

FIRST start logic, then assign Renoise to one of its aux tracks, then launch Renoise and it will ask to run as ReWire slave.

You can not slave Logic to Renoise. Logic only support the ReWire master mode.

Here is a small video tutorial on how to ReWire reason to logic. Simply exchange reason with Renoise here:

Umm, I know the order to start my programs in… I already said that. I know how to set up rewire in both logic and Renoise. I am talking about something my computer programmer friends can’t figure out.

Here is what happened

Someone showed me Renoise, I installed it, and thought to myself: ‘hmmm’ this would be sick to use as a rewire slave’. Later, I Opened Logic. I opened Renoise. The first problem that happened was that renoise did not recognize that it was a slave to Logic; I know this because it did not give me that pop up window that is demonstrated in the tutorial. Then, Renoise froze when I tried to go in the preferences. I restarted my computer. Since then, LOGIC (AND PROTOOLS) DID NOT AND WILL NOT OPEN, NO MATTER IF RENOISE OR ANYTHING ELSE IS OPEN. Renoise has not been on my computer since that day, I deleted every instance of it. I fixed the Protools one by disabling PT’s abilities to host rewire slaves. I can’t figure the Logic one out. I get a bus failure, and the error report points to a problem with the kernal pertaining to rewire.

Thank you everyone for trying to help, but please read the thread first.

What version of Logic are you using? And which version of Osx? I have Logic express 8 and I can rewire Renoise into it np. Osx version 10.5.8

My Logic still works fine stand alone as well. Have you tried to re-install Logic? Are you using Renoise 2.1 or higher?

As far as the order of which program was installed first, Logic then Renoise.

Edit* I use the program CleanApp whenever I want to take a program off my Mac.

I’m using logic 9.0.0, and os 10.5.8. I am not surprised yours and probably most worked; I don’t what happened with mine. No, I haven’t tried to re-install Logic, I didn’t think I was going to have to. By this point, I’ve spent enough time on it that its worth a try. Also, thanks for telling me about cleanapp, I just saw the other one was for windows :D

Hi, I’m bumping here because I still have this problem…and before I uninstall everything and reboot leopard, I still think that something can be done about this…is anyone here saavy with error reports?

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 15

Thread 15 Crashed:
0 ??? 0000000000 0 + 0
1 ??? 0x3ab6fcb0 0 + 985070768
2 libSystem.B.dylib 0x924f70c8 _pthread_start + 320
3 ??? 0000000000 0 + 0

Thread 15 crashed with PPC Thread State 32:
srr0: 0x00000000 srr1: 0x4000d930 dar: 0x63462000 dsisr: 0x40000000
r0: 0x00000000 r1: 0xf079cde0 r2: 0x02e3fc00 r3: 0x32a0da20
r4: 0x02e3fc00 r5: 0x00000000 r6: 0x00000001 r7: 0x00000001
r8: 0x00000018 r9: 0x00000004 r10: 0x00000008 r11: 0x00000000
r12: 0x02e3fc00 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000
r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23: 0x32a0da20
r24: 0x00000000 r25: 0x32a0e0f0 r26: 0x32a0e0f0 r27: 0x32a0e104
r28: 0x02e983f0 r29: 0x02e3fc00 r30: 0xf079d000 r31: 0x02e82520
cr: 0x48000024 xer: 0x20000000 lr: 0x3aba94ac ctr: 0x00000000
vrsave: 0x00000000

If anyone needs anymore, I can provide it!!!

Thanks anybody!!!

Is your version of Logic a PPC edition? if so, can PPC and Universal Binary applications talk with eachother through ReWire at all?(Generic question to all)

I’m not sure at all; I thought ppc used universal binary

Anyone??? B)