"Solo" Or "Mute" For Plugins With Internal Sequencer

Hi,

I tell you about that problem some days before via mail. So here again …

If I use an AU or other PlugIn in ReNoise, I can only use “SOLO” or “MUTE”-Button in Mixer of ReNoise, if the sounds from that PlugIn will be played by MIDI-Data in the track from ReNoise. Example: I load a Pattern and some loop in BPM, set BPM to sync and autostart. So BPM starts right while playing ReNoise, but if I switch another track from ReNoise to Solo then BPM plays allways too (it must MUTE!!). If I switch a BPM-Track to SOLO all other tracks muted but not the seperate Outputs of BPM. I cannot solo any separate Output.

Ok, it´s like that: if a PlugIn will not been played via MIDI from a ReNoise track, then you can´t mute it and it will not be muted if you set another track (another Plug) to solo. SO (question) is it like that: MUTE is like: mute the source from a track (before it comes in the MIXER-Slot) NOT (like it has to be) the audiooutputsignal from the MIXER-Slot will be muted.
I think thats a fatal problem. It happens with all Plugs that will not have any source in the MIDI-Track?!!! Is there a workaround? (a trick with live-mode-remote does´nt work and many loop in BPM or UVI-eng. are not sliced and don´t have to be sliced because the better result without slicing)

Or is there a switch: mute sourcedata / mute audioout ?? that will fix this.

And it´s really no Problem of the PlugIn, I checked in other sequencers and there it works really fine.

See http://tutorials.renoise.com/wiki/Preferences#Misc please

Mute mode (left click):

  • Off: After a track is muted, any existing sounds may carry on until finished, but notes and other events will not be triggered (Soft Mute).
  • Mute: The track is played back completely and can be immediately silenced/unmuted without affecting how any of the sounds are executed (Mixer Mute).

Solo mode (right click):

  • Solo: Solo-ing and unsolo-ing track will retain the mute states of all other tracks.
  • Mute all others: Solo-ing a track will cause all other tracks to be muted. Unsolo-ing will unmute all other tracks.

You can also quickly toggle them in the “options” menu in Renoise.

Thank you very, very much :slight_smile: !! sorry I´d not found,

so now I´ll look first for a tutorial because will be fine if we can define that while SOLO / MUTE the Effekt-returns won´t be muted too by default … I´m shure you thought about that and I´ve to search for that feature – I´ll do now …