[Solved] ASIO distorted sound

Hello Renoise!

I have Windows 8.1 Pro 64bit and I’ve been recently trying Renoise 3 rc2 64bit. Again, I searched forum and couldn’t find the same issue.

The problem – almost everytime (~80%) I launch Renoise with ASIO4ALL v2.11 Beta1 and I play some sound or song, the sound that comes out is distorted a lot - it’s almost unrecognizable - sounds like hiss but I can hear the melody or beat in it. I have to “Reinitialize” ASIO from Preferences/Audio/Device Settings and then it’s normal again. I managed to reproduce this problem several times but I’m not sure how to record or capture it. It never happened with DirectSound. I’ve been normally using Renoise 2.8.2 and it never happened. It never happened with any other application.

Main reason for posting this is to let you guys know about this but also to ask how can I help else? Should I try to record the sound somehow?

Try fiddling with the asio control panel, particularly the buffer size, but avoid ticking Enable hardware, tends to crash renoise for many.

buffer setting too low.

Hello and thanks for those tips!

Unfortunately, adjusting buffer size didn’t help. And I also tried playing same song in 2.8.2 and 3 rc2 - it never happened on 2.8.2, on 3 rc2 it happens very often. And as I stated previously, it also didn’t happen in any other application using ASIO drivers.

I also have more description of sound - now it sounds to me like several distorted and delayed layers of played sound. It seemed to be just hiss when I played single instruments but when I played whole song I could actually hear the song, just distorted.

EDIT: my ASIO buffer size is set to default 512 samples


Version 3.0.0 brought big improvments, now it happens only in 10% of launches. I usually click reinitialize and it’s okay. Anyway, it’s weird that it never happened with version 2.8 or with any other application.

try to set up sample rate from 44100Hz to 44800Hz.
in my case with asio buffer 64samples i got hiss with 44100Hz but never with 44800Hz ;)/>

48000HZ you mean :)

yep, thanks, forgot and corrected that, not just dropping some random numbers :)

Thank you for tip, I just tried it few times, unfortunately it happened again… :stuck_out_tongue: I’m not really sure what is the source of this problem, but it happens only with asio and only since version 3.

To finish up this topic, I don’t have any problems since new ASIO version, so it’s solved :slight_smile: