[Solved] Cpu, Linux Vs Macintosh

Sorry, I’m the first to roll my eyes when it comes to CPU threads but, with a brand new laptop running a new OS I have to ask…

All things being equal, we can agree that when I look in the upper right corner Renoise, then look at the CPU percentage, this number is measuring the same thing on both my Linux laptop and my Macbook Pro, right? Sure each computer is doing a bunch of different shit, we can talk about that for ten pages, but at the end of the day Renoise is measuring the same thing because that number comes from Renoise, right?

When I play Pattern 6 in DemoSong Dblue Synthetic Sugar:

Linux: ~40%
MacBook: ~20%

The problem here is that my MacBook is 3 years old. The CPU is a “2.53 GHz Intel Core 2 Duo” My Linux box is a Lenovo X220, which I maxed out with a “Intel Core i7-2640M @ 2.80GHz × 4” .The first has 2 cores. The second has 4. Etc.

I expect the opposite to happen.

In the above test, each computer is running at maximum core capacity (lol wut?). I thought, "OK, well what if I set it to just 1 CPU in Renoise. (/me right clicks on CPU, changes it to 1 CPU on both computers…)

Linux: ~50%
MacBook: ~37%

Latency on OS X is 15, Linux is 17.4 (Buffer Size 256, Periods 3). /etc/security/limits.conf edited in accordance with the Linux FAQ.

School me.

Also, when loading:

CPU: Found 4 enabled unit(s) with 8 core(s) / 16 logical processor(s) per unit. 4 cores, 4 logical processors are enabled in total.  

From 2.8 release notes:

Hyper-threading support for new Intel i5 and i7 CPUs and others  

I remember reading somewhere in the forum, during the 2.8 release cycle, something along the lines of “I’m so happy now, Renoise uses all my cores!”

I have 4 CPU’s available to me under Renoise. Is Renoise using all of my cores? (/newbie)

What does the OS task manager say?

The CPU meter in Renoise is not very reliable, I find sometimes.

I just checked it with the same pattern 6 from the song you were testing with, on a single core I get around 27% load with the Renoise meter and 7% in the task manager.

On four cores enabled there is about 19% load in Renoise and about 9% in the task manager.

The testing was on a four core i5, not sure about the clock rate, I think it is 2.6GHz. Win7 64 is the OS.

Either Linux is not an efficient audio environment for any DAW or Renoise is not efficiently using CPU power or Linux is not efficiently configured.
I guess in the majority of cases, one need to really tweak Linux first before you can get some decent results.
Out of the box, Linux can be quite a poor performer. I already noticied this with UBuntu and UBuntu Studio.
But i left the field whenever Pulse audio came into play.

I don’t disagree with this statement. But, it should be equally unreliable across platforms. (Windows, Macintosh, Linux)

That meter is measuring something. I find it hard to believe that the measuring changes for the worse after I significantly upgrade my computer specs, but change the OS.

Is it a GUI thing or what?

It has never been clear to me what that CPU is supposed to be measuring.

Tweak what though?

In theory, Renoise has a better CPU to work with but is performing worse. In practice what is happening? What is being measured here that makes it worse now than before on a less powerful Macintosh?

Just rebooted into my Windows partition.

Windows: ~40% (sometimes 50%)

No idea what to make of any of this. My instinct is to ignore this stuff until it actually affects me, but there’s still a lot of unanswered questions.

More specifically:

  • The CPU meter is equally unreliable on Windows and Linux on my new computer?
  • The CPU meter is lower on my older, theoretically slower, computer. Why?

Your new computer is not using some idle power saving mode right? Because this is forcing your cpu to go into some idle state until its powers are demanded again, but this feature is highly ineffective with audio and video processing apps.

if you have your cpu governor set to ondemand try setting it to performance. this solved performance problems on my arch box.

Ok, I managed to figure this out on my Windows partition.

This X220 laptop comes with some sort of “Lenevo Power Plan” app. If I switch this app to advanced and choose “Maximum Performance” I get the performance I was expecting. This is one of 6 default power plans, and these 6 advanced plans are totally different than the offerings in Basic mode. Totally complicated for no reason. Bravo Windows with an extra layer of Lenovo crapware. Bravo. Future Windows hardware developers reading this: Can you at least try working with a Mac Laptop for a few weeks? Because from where I stand this is fucking stupid.

Snide remarks aside, thanks for your help so far everyone!

Now on to Ubuntu:

Cool, how do I configure this in Ubuntu 12.04? All my searches end up with conflicting information. The most reasonable explanation I found so far is:

sudo update-rc.d ondemand disable  

But then it says I have to reboot. That seems kind of anti-linux. Ideas?

Ok, that was easy. There’s an app in the Ubuntu Software Center that does the job.


I search for and install that (sudo apt-get install indicator-cpufreq), logout, login, all is good!

Windows hardware developers: Look to Ubuntu, too. ;)

I had to switch off this feature in BIOS at one stage.


Conner -
I see this is marked solved, but I’m curious…

What linux kernel are you running? What DE are you running? And are you just running just straight up ubuntu?

These are huge factors which I dont see any mention of when you are referring to benchmarking.
Remember ubuntu just off the live cd is designed to be all things for all people.

I’d recommend looking at running either alow-latency or RT kernel in linux. Stay far away from the Unity DE and give LXDE or XFCE a spin.
AVLinux straight off the live disk usually gives me great performance as well, without needing to tweak much. AVLinux is based off of Debian Squeeze.


Thanks for the advice Rob.

The problem was the “CPU governor” and setting it to “Performance” solves my issue.

I’m aware there are other issues with my setup, but Renoise is not my fulltime gig. I’ve been using Linux at work since last year, and have always ran Linux webserver. Before my switch to OSX in 2003 I always had some sort of Linux partition (Caldera, Corel, …, I always seemed to pick the losers, Ubuntu foreshadowing? lol)

I like Ubuntu 12.04 LTS for what it is. Coming from OSX, I like Unity. I can live with this setup now. If I run into more issues I’ll start a new thread.


Conner: out of pure curiosity, what does the renoise’s meter show now?

Between 4% and 5% better than the Macbook. (eg ~15%)