[solved] Crackles When Rendering Songs with izotope Ozone VST

Couldn’t find any forum post on this so…

I get regular and very deterministic crackling when rendering with too low latency. The song uses an East West VST with tons of samples, but doesn’t use more than 35% CPU. I usually work with 256 samples->5 msec latency and have no problems with normal playback, but I have to increase it to 25-50 msec to get clean rendering. Also, DirectSound or ASIO makes no difference.

I didn’t think output latency would affect rendering…?

Have you tried using a different rendering priority? (Available to change in the rendering dialog box itself).

Some VSTs seem to get confused when they are being processed at faster-than-realtime speeds, so you may want to experiment with the “Real (plugin compatibility mode)” option to see if this helps at all.

Yep, tried all priorities, as well as both interpolation methods (since arguru’s is much slower I thought it might help). It’s not actually the VST that crackles, though. Even parts with plain old samples drop out, and the crackle/drop always happens at the same spot.

latency does affect rendering when you use the realtime priority, and since EW VST instruments should be rendered in realtime mode in order to avoid crackles, you end in experiencing crackles all the time.

yes, your CPU is not used at full, but probably your HDD is. I use Symphonic Orchestra since a couple of year, so I know what I’m saying…

since you are using an EW VST, I think that a superlow latency is not really the most important thing for you, so you should be easily able to find a good compromise between latency and performance.

But its indeed strange that a higher latency solves this for you. Audio IO is completely bypassed while rendering, so this should not make a difference.
Probably theres another VST somewhere which causes the crackles? Something in your master track?

Could you please try to narrow down the problem, try to find out which FX or which settings seem to cause this? You could also try if disabling PDC solves this.
Does rendering some of the (VST free) demo songs in Renoise always work, whatever latency you are running at?

It can be what IT mentioned: EW plugins tend to stream their samples from disk and if the harddrive is not that fast (5400rpm IDE) or severely fragmented, those are areas to deal with.
If you can turn off the disk-streaming mode (DFD), this may solve the crackling perhaps as well.

It is a known problems of EW (or NI) sampler plugins… the newer Play plugins should currently deal a lot better with these issues.

Well, I found the culprit. Turns out everything else is basically innocent, but the izotope Ozone VST tacked on the end of the master chain is what’s causing dropouts at low buffersizes. Not sure what to make of that…

You could try if changing the compatibility settings for this plug in Renoise solves these problems. Click on the small “?” button next to the “Ext Editor” button in Renoise, then try changing the “static buffer” option.
If this helps, could you please let us know at which setting it worked. Upgrading the VST to the latest version might also help.

Turning on static buffers helped for Ozone 3. I downloaded Ozone 4 and it doesn’t seem to have any problems.

i have this issue too, if i use ewql vst-s
but i figure out how to fix it:
render parameters:

  • Arguru Perfect sync
  • priority : Low (in background)

and i never hear that crancle sound again,