[Solved]Experiencing Difficulties To Work With E-Mu Emulator

Hi Everybody,

Long-time user of OpenMPT, I’m looking for another tracker which could work perfectly with my new software sampler, Emulator X3, as OpenMPT has some annoying issues with it.
So, I’m trying Renoise since a few days, and I must admit that I love many aspects: familiar interface (I can’t compose with anything else than a tracker), modern features, reasonable pricing, consistent community…

But, currently, I don’t get good results with the E-MU Emulator X3 software sampler (VSTi) after trying to work with it for several days.
That’s why I’m posting here.

The main issue is related to latency problems.
My test project is one of my previously published IT songs, Green Hills, 20 channels, 22 instruments, imported into Renoise.

In Emulator X3, I can load several instruments at once, mapped to different MIDI channels/banks/programs.
So I create a single instance of Emulator X3 into Renoise, into which I load a dozen of instruments.
After, I assign each of them to an instrument in Renoise. I’m using VST aliases as I guess that’s the most power-efficient solution.

But, despite of using only one instance of Emulator X3 for all instruments, the notes are playing with a noticeable latency.
I can easily hear it while listening to the bass line, which consists of one note per pattern row (speed 6, BPM 130, 64 notes per pattern).

I’ve noticed that latency increases if I increase the number of instruments linked to the VSTi alias.
If I listen to my original IT file with simple instruments using the internal sampler (no VSTis), there’s no latency at all.
I’ve tried to use a separate instance of Emulator X3 for each instrument (no aliases), no luck.

I don’t think that it’s an hardware issue, as I have a MOTU UltraLite soundcard, running on a powerful PC (Core i7 920/Windows 7 x64/6 GB RAM/2 x RAID0 HDDs).
As I only have the demo version of Renoise, I can’t check whether ASIO would solve the problem…

Please notice that I don’t have this problem with the same song loaded into OpenMPT or REAPER.

  • OpenMPT has more problems than Renoise with it, but nothing related to latency.
  • REAPER works absolutely flawlessly with the same song (converted from IT into MIDI) and Emulator X3 instruments (2 instances). The problem is that I simply can’t compose with sequencers… trackers are so much easier for me!

Have you got any ideas about these latency problems between Renoise and Emulator X3?
What can I test to find where is the problem?
I’m ready to give many more information about my setup, instruments or songs if it can help you.

I’d really appreciate to hear from you.
Renoise is not expensive, but this latency problem prevents me from buying this software.
I can’t afford any commercial program until I’m sure that it would work flawlessly with my setup!
That’s why I prefer REAPER’s demo approach. Being able to test it without any limitations, I’m sure that it would perfectly work if I buy it!
But not Renoise. Disabling ASIO support in demo version is not a good idea, IMO.
If I buy Renoise and discover that ASIO support suffers from the same issues, I would feel like I spent money for nothing!

Many thanks for any advice or answers.
Regards from France,
Maxime

Still no answer to my post…
Did I miss something?
Do you need more information?

That the amount onf latency seems to increase with the amount of plugin aliases that you add, sounds very strange. Probalbly theres a bug involved. I don’t think using ASIO will change this at all - at least not when the latency seems to increase over time in the song.

But its really hard to say what exactly the problem is without seeing the whole thing - the whole song. All I know from the posts here, is that this EMU sampler synth created a lot of problems in the past in Renoise - maybe also in other hosts. The EMU sampler also is not THAT advanced. Couldn’t you simply use Renoise samples for that in this case? Then you at least know what you get.

I think it would be a good start to share/send us the XRNX song you have the problem with, so we all can have a look at this and try to find out whats exactly going on there…

Many thanks for answering so quickly after my last post.
I missed your reply :s

To answer your question, I don’t plan to use Renoise’s integrated sampler, as E-MU Emulator X is able to re-import all sound sampling stuff I’ve built since many years (SoundFont banks).
Using Renoise’s integrated sampler means that I would have to rebuild each instrument from scratch, like I used to do in OpenMPT/ModPlug Tracker, as it barely handled multilayered SoundFonts.
It’s a very big time-consuming task, and that’s why I’ m looking for other software which could help me avoiding this hassle.

Your theory about latency related to the sampler itself rather than buggy ASIO or DirectSound doesn’t really sound good, as it would mean that I’d have the exact same problems with the paid version of Renoise.
So I need to know how to solve this issue before considering any purchase.

I guess it’d be quite difficult to share my Renoise song if it remains attached to Emulator X, which is a paid product that many people don’t own.
I’ll try to build the same song using the free Proteus VX sampler, which uses the same engine (and suffers from the exact same problems in Renoise IIRC) and I’ll upload it here ASAP.

I can now give you some feedback about my problem.

I’ve built three test files, based on my latest song to date, “Green Hills”, originally in IT format (composed with OpenMPT), 20 channels, 23 instruments.

  • First test: I open this song into Renoise as is, correct sample basenotes (not imported), and save it into native XRNS format.
  • Second test: From this XRNS file, I replaced all integrated instruments by two instances of E-MU Proteus VX, first instance holding all instruments except two (including a drumkit) which are held by the second. Then, I removed all samples from Renoise’s integrated sampler, saved the contents of the two Proteus VX instances into two distinct sound banks, and saved the song into a second XRNS file.
  • Third test: From this second XNRS file, I simply replaced the two Proteus VX instances by two instances of Emulator X3, and reloaded the same previously saved banks into each.

Here are the results:

  • The first file (integrated samples, no VSTi) plays flawlessly.
  • The second file (no integrated samples, two Proteus VX instances) also plays flawlessly.
  • The third file (same as second file, but with Emulator X3) plays with a huge latency, as described in my first post.

So, I suppose that the latency issue might be related to Emulator X3, as it doesn’t occur with Proteus VX.
Anyway, I’m stuck, because I don’t know what to think about that:

  • The fact that Proteus VX works flawlessly would mean that it’s not related to Renoise.
  • But, Emulator X3 works flawlessly with REAPER, using the exact same sound banks and original song file (in MIDI format), which could mean that it might indeed be related to Renoise.
  • I have a strong machine, as said above, so I don’t think it’s a performance issue between Proteus VX and Emulator X3…

Given these results, would you still be willing to help me?
Or do you consider that my problem should be handled by E-MU, and not the Renoise team?
I’m okay to send you my test files and sound banks if you think that you can work on this issue.

Many thanks for your support and expected help.

Maxime

Only a few things that come to mind to test if i would have this problem with a certain plugin:
-Toggle the “Use Static Processing Buffers” option in the VST plugin options (click the question mark in the plugin frame inside Renoise) . (If it is on, turn it of or vice versa)
-Fumble with the frame-rate in the GUI preferences.

Yeah, you’re the best! :D

I can’t believe it…
Checking this little, discrete checkbox has completely solved my latency problems with Emulator X3! :blink:
That’s awesome, I was close to give up! :wacko:
If I uncheck the box while playing my song, the sound suffers from latency issues. And if I recheck the box (while playing), latency disappears immediately. Straightforward workaround, couldn’t be simpler and better!

However, I don’t understand why I didn’t encounter this problem with the Proteus VX version of my song at the first time.
I’ve made another test: I reloaded the Proteus VX-enabled song I created, and saw that this checkbox was ticked.
I unchecked the box… and the exact same problem also occurred with Proteus VX!

So, I don’t know why it used to work with Proteus VX, although I didn’t explicitely checked this box…
Do you maintain some kind of internal plugin compatibility list, on which Renoise relies to decide whether some compatibility tricks should be enabled or disabled by default, depending on the loaded plugins?

Anyway, many, many thanks for pointing out this option.
Now, I can go further on and discover all Renoise features to check if it suits all my needs…

As part of my learning session, I already have several questions to ask to your team about some stuff I don’t understand yet.
Should I continue to ask questions on this particular thread, or do you want me to open a new thread instead?
That would be mainly MIDI and Emulator X3 related questions, so I don’t know where to ask…

Many thanks!
Maxime

Yes, the plugin-database that is built up has a list of known plugins that need this trigger.
So i guess we can safely add theE-Mu Emulator X3 to the list… can you post the Unique ID? (hover above the question mark and wait for the tooltip -> third line from above)

Sure!

Emulator X3 Unique ID is 1162696024.
Name: Creative Professional: EmulatorX
Vendor: Creative Professional
Number of parameters: 256
IsSynth, Receives MIDI, AutoSuspend, Static Buffers, Supports MP: all YES

I suppose that the same problem may arise with previous versions (Emulator X, Emulator X2) but I can’t confirm that.

Glad I could help anyway!

Now, I have to work further on this plugin and my songs to ensure that Renoise fits all my needs.
I’ll have more questions to ask about it, now that I’m sure that customer support is here to help!

I have some issues with panning and volume effets ATM (classic volume and panning commands are not sent to the plugin as MIDI commands -> no effects applied on the plugin sounds), but I’ll open another thread about this unless you give an answer here.

Many thanks!