[solved] Focusrite Liquid Mix VST PDC Problems

Hi guys,

I experience following problem when using Renoise 2.1.0 with Focusrite Liquid Mix - there is too much latency compensated when using Liquid Mix plugins. As a result all tracks where I have Liquid Mix plug-in inserted are played about 2-3ms faster than other tracks without any instance of Liquid Mix inserted.

I don’t have this problem with Renoise 2.0.0, when I use Liquid Mix plug-in there everything plays in perfect sync.

I compared informations about Liquid Mix plug-in from Renoise 2.0.0 and 2.1.0 and it seems that both Renoise versions detect same amount of latency - 8200 samples:

Any ideas ?

you can compensate the plugins manually in the mixer tab for those plugs that give wrong pdc info to Renoise

Okay do you use PDC in 2.0 as in 2.1 as well?
If you only use that specific DSP plugin with one internal Renoise instrument (no other VST effects or instruments). Use one track with your VST plugin as effect and a bald track next to it using the same instrument. Now can you experience your Liquid Mix track is lined up correctly to the bald track?

Yes I used PDC in 2.0.

That’s exactly how I tested - I had two tracks with the same instrument playing the same sequence. As soon as I inserted LiquidMix plug-in to one of tracks in Renoise 2.1 it started to play faster (too much latency compensated).

After a several tries to make it work it is working fine.
Here is what I’ve finally done:

  • uninstalled Renoise 2.0.0 and 2.1.0
  • uninstalled Focusrite Liquid Mix (plugins and drivers)
  • installed Renoise 2.1.0 only
  • installed Focusrite Liquid Mix (I didn’t change default Liquid Mix manager options)
  • run Renoise 2.1.0 so it could detect all plugins again.

I’m not sure if you should move this thread somewhere else, it’s hard to say if it’s Renoise bug or LiquidMix problem.

Anyway - thanks for your support guys !

If reinstalling fixed this, there may have been something wrong somewhere in the configuration. Since it worked flawless in Renoise 2.0, maybe copying the Renoise 2.0 configuration had a flaw during the first setup of Renoise 2.1, either in the final but possibly also in one of the beta’s.
Once the configuration has this flaw, it remains there until reconfigured from scratch.