[SOLVED] Help with DSSI_Path and linking the plugin FluidSynth to it

Hello guys. I am trying to move away from Windows so therefore I must also move away from FL Studio. So far everything on Linux is configured to my likings, except Renoise’s plugins.

With Linux I am noob when it comes to compiling things, so I am totally confused now:

steps I took:

  • ran automake on fluidsynth folder

  • ran cmake on fluidsynth folder

now I get the some of following folders:

/usr/local/include/fluidsynth <-header files

/usr/share/doc/libfluidsynth1 <-documents

/usr/local/bin <- executable

So I should adjust the DSSI_Path it says under preferences, but where am I to adjust it to?

I guess the solution is pretty easy but I’ve been spending hours for a fix already, please help me out.

Thanks in advance.

Edit: I reinstalled FluidSynth from the ubuntu package center but still no dssi folder :frowning:

Edit2: What I should have done was sudo apt-get install fluidsynth-dssi, everything works fine now! :wink:

Hello guys. I am trying to move away from Windows so therefore I must also move away from FL Studio. So far everything on Linux is configured to my likings, except Renoise’s plugins.

With Linux I am noob when it comes to compiling things, so I am totally confused now:

steps I took:

  • ran automake on fluidsynth folder

  • ran cmake on fluidsynth folder

now I get the some of following folders:

/usr/local/include/fluidsynth <-header files

/usr/share/doc/libfluidsynth1 <-documents

/usr/local/bin <- executable

So I should adjust the DSSI_Path it says under preferences, but where am I to adjust it to?

I guess the solution is pretty easy but I’ve been spending hours for a fix already, please help me out.

Thanks in advance.

Edit: I reinstalled FluidSynth from the ubuntu package center but still no dssi folder :frowning:

Edit2: What I should have done was sudo apt-get install fluidsynth-dssi, everything works fine now! :wink:

You need a DSSI plugin for it, there should be a package for it which would be installed in to /usr/local/lib/dssi which you would add to your DSSI_PATH if necessary. However, I think the bigger issue here is you compiling them, why are you doing that? Fluidsynth is available is pretty much all distro’s repos and package managers. If you start compiling things manually 1) you’ll forget to update them 2)you can cause issues with things you install through a package manager and create file collisions 3) miss dependencies or have the wrong versions 4) generally make a mess of your system.

If this is a new install I would suggest a dedicated distro like kxstudio or avlinux, or you can add kxstudio repo to debian or ubuntu based distros and load the desktop settings from there which will tweak a few things in your system to make run much better for audio programs.

You need a DSSI plugin for it, there should be a package for it which would be installed in to /usr/local/lib/dssi which you would add to your DSSI_PATH if necessary. However, I think the bigger issue here is you compiling them, why are you doing that? Fluidsynth is available is pretty much all distro’s repos and package managers. If you start compiling things manually 1) you’ll forget to update them 2)you can cause issues with things you install through a package manager and create file collisions 3) miss dependencies or have the wrong versions 4) generally make a mess of your system.

If this is a new install I would suggest a dedicated distro like kxstudio or avlinux, or you can add kxstudio repo to debian or ubuntu based distros and load the desktop settings from there which will tweak a few things in your system to make run much better for audio programs.

Thanks for the much detailed response. Forgot to mention I am running Ubuntu. So I uninstalled the compiled packages. And reinstalled them from the ubuntu package center. But I still have no dssi folder, just the application, header files etc.

You need to install the package for the DSSI plugin -http://packages.ubuntu.com/search?keywords=fluidsynth&searchon=names&suite=trusty&section=all

So you should havefluidsynth andfluidsynth-dssi installed.

You need to install the package for the DSSI plugin -http://packages.ubuntu.com/search?keywords=fluidsynth&searchon=names&suite=trusty&section=all

So you should havefluidsynth andfluidsynth-dssi installed.

I figured that out by now but thanks for your help still! :slight_smile:

Cool, glad you sorted it. I do recommend adding the kxstudio repos to your system, you can easily install lots of very nice plugins and synths.

http://kxstudio.sourceforge.net/Repositories