[Solved] Instrument Envelope Stops Looping

I couldnt reproduce it on a plain new song , so you have to figure it out with my track.

After you loaded the song, go on track 7 and instrument 8.

Play the song and keep your ear to track 7.

Go to the instrument envelope of Instrument 8.


If you move the endpoint of the Volume-Loop to the left, you will hear all three notes, if you put it back to the end you will hear only those instrument, which has 50+ ( i think ) velocity, others are muted.

If you put a point near the end-range marker,and pull it up to anything beside 0,00% you suddenly hear all three notes again.
Could also be, that i messed up anything, thats why i couldnt reproduce it.

Long Version:
Must admit this is super strange. Took me a while to find out what’s happening here as well: Problem is that the song is a very old RNS song which never was upgraded. Old songs, old Renoises had a strange way to stop inaudible samples (samples at -INF vol) - as seen in your example. To be fully backwards compatible, we could only fix this for upgraded songs, new songs.

Short version:
Go to “Song Settings” -> click on “Upgrade to latest Version”

ok, thanks for helping me out :)