[Solved] K-Meter Vst On Mastertrack Weirdness

I first noticed this today, when I had the metronome active in an otherwise empty song. (I rarely used the metronome before.)

The only DSP I have in the “song” is the VST K-Meter (Stereo) by mzuther on the master track. This shouldn’t affect the sound at all, right? But still this kind of doubled up, reverbed, cancelled out the metronome sound for me.

Next thing I tried, I switched the metronome off. Instead of it, I faked the metronome by some notes and metronome.wav as an instrument. Then I rendered 8 bars - with the same awful result, also visible in the waveform. This happens even when the DSP is deactivated.

Now what’s even fishier I guess: I appended Voxengo SPAN to the mastertrack - still the same crappy effect - but then I changed the DSPs’ order, et voila! K-Meter not in the first position in the DSP chain and everything was fine!

Even with both DSPs deactivated, the change of order makes the difference…

Can anyone confirm this?
I’m running WinXP 32bit, renoise 2.8.1 32bit.

Both VSTs are available on KVR.


Edit: Tried various plugin compatibility settings without success.

Edit2: Tried various versions of renoise starting from the 2.1 demo, all with the same effect.

Edit3: Tried with reaper v4.25, K-Meter on the master FX without any issues.

Even though this problem might seem to be urgent to me (considering my edit frequency), it isn’t! :D

Effects on the master track affects all audio going through it, that goes for the metronome and i believe for the sample preview as well, but not sure about the last thing.
That you disable VST effects doesn’t mean that the dsp doesn’t stop affecting the audio stream, what happens if you hit the stop button twice (panic activation), does that stop the VST from performing when it is deactivated?

Uhm, K-Meter is a metering tool - it shouldn’t have any sound effect at all, same as SPAN (at least this is what I thought so far). If I hit stop twice, well, yes, everything stops. The weird thing is why does a VST which is meant for metering purposes only, alter the sound? And when I rearrange the order of K-Meter and SPAN the way SPAN comes first, this unwanted effect is gone?

Something must be wrong in my setup, I never noticed this before.

Wooh, I think I got it! I think I did something wrong when I tried different compatibility options. Seems it works fine for me like this:
[] Use static processing buffers
[] Auto suspend plugin when silent
[x] Can run in multi processor environments

Feeling a bit stupid now. ;)

Anyway, thanks vV :)

PS. Still funny it works with auto suspend on if it’s not the first in the DSP chain.

Yeah it should only measure, but there can be a lot of things that affect sound anyway regardless of the plugin its function.
An easy overlooked thing e.g.: The VST plugin can only process 44Khz 16 bit but the audiocard preferences are set to 48Khz or 96Kbit and 24 bit.
In that case, the plugin receives a different bitrate than that it can spit out. I’m wondering if it is at all possible for a DSP plugin to tap into an audio stream, rather than just inputting and outputting it.