[Solved] Keyboard Again Does Not Work :(

oh man… 2 days ago i thought i had found the issue, today again nothing happens, no matter if i switch the (computer) keyboard to another usb port, restart or reinstall renoise, again nothing, none of the keys is working.

i don’t know what to do now as i tried everything i could do besides a direct x update (that does not work as the newest version (11) is already installed, uninstalling renoise, new installation, deleting the keybinds… this is really crazy as i work almost 8 years in renoise now and never had such trouble.

also, i seem to be the only one having those issues?
maybe i should try another keyboard, but as it works in windows vista, this is not very promising …
anyone still some hints?

many thanks

I guess you obtained some kind of malware that revived.
And regarding the malware that came with Firefox, I installed Firefox today on a system and there was no optional toolbar or whatever crap i got offer to install extra.
the only suggestion i can make is do a proper malware scan or perhaps use HijackThis and offer the results to one of the many forums around where people can help you out with suggestions after they analized the report.
HiJackthis is your best shot.

made several malware scans, nothing relevant on the system besides some false alarm of (necessary) cookies. is there a tool to completely remove direct x 11 in a safe way from the system? if so, i will try that and reinstall…

direct x new installed, renoise again new installed, nothing. man it’s incredible what’s goin on with this… can’t reinstall the whole system, much too much applications and stuff i urgently need for working purpose…
maybe just one question to the developers of renoise: i need to know if/where there are hidden renoise files, maybe for keyboard control, direct x, etc. for example in system directory etc.,
i need to be sure to delete everything to try again…

There are no such hidden renoise files, and sorry, but I’ve absolutely no clue why this happens. Will definitely be some sort of driver, DirectX problem. To verify this, could you try out if some games (something which uses DirectX) suffers from the same problem?

If it is a problem in the operating system, you could try to use an earlier system restore point or windows repair install. Repairing should leave your programs, accounts and other personal data intact and only copy over system files.

i don’t have many games on the system, tried with grid race driver, works properly. maybe i’ll try the windows repair install (i need to check first if available, as i cleared
all restore points).

maybe found the issue (i’m a bit more careful now as i don’t want false alarm again, so i will double-check the next days)…

i’m using the software “pinnacle tv center” for years now, until 2 weeks ago in it’s version 4.9 (that was very old/took much resources/slow when switching through channels)
i had installed pinnacle tv center version 6.3 2 weeks ago:


it is much better regarding the speed, but… as it seems now, responsible for a complete lockup of the computer keyboard in renoise (yeah, complete, as not any single button works anymore).
i have uninstalled it some minutes ago, opened renoise 2 times, everything fine (besides countless tries before when keyboard had no function anymore).

unfortunately i have to install pinnacle tv again (as i need it for tv watching/recording purpose), theres a slightly newer version 6.4 available, i will try that,
if the problem occurs again i will let you know (and if i can really confirm only this was the issue), maybe we can find out what’s responsible for that, maybe a driver, a plugin.

as the TV center app became a huge program (realtime recording video/audio in the original format, converting, many plugins and for sure massive direct x use), i really can imagine
that some small extension of the program blocks some memory reserved for renoise…

that was it… TV center by Pinnacle is the blocker! i should change my TV card (and software) …
would be interested if it causes the same issue on other computers.

no matter if 6.3 or 6.4 version, both block the keyboard in renoise.

pinnacle replied yesterday with a (temporary) solution - maybe helpful for any other renoise that uses tv center.
i had to go under options and choose “no remote control”, and had to reboot the pc.
after that the driver for remote control is not loaded, and renoise works again.

Thanks for your report Christian, we’ll keep this topic archived if another user bumps against this one.