[solved] Linux: Can't Get Inputs To Work On M-audio Delta 44

This is really frustrating. I spent 2 hours last night trying to get my line-ins working to no avail. I have verified on my windows install that the audio source is connected correctly because it works there.

I have installed “Envy24 control Utility 0.6.0” which can monitor the inputs/outputs of the M-audio card and change settings and such. I have made sure I un-muted the input tracks in it.

Here are the things I have done to troubleshoot:

*I have gone into Ubuntu’s sound preferences and changed the “sound capture” and “default mixer tracks” to every single option in the list. (Thinking that maybe it had to be a certain one in order for line-in to work).

*I have gone into the “system tray’s” volume control and fiddled with the settings on every single device listed, making sure that none of the microphone icons had a little red X over them, making sure levels are up… etc. I read on some forum thread that you had to make sure there was a little box checked that said “capture”, but from what I gather that is for older ubuntu builds as 9.04 one doesn’t have anything like that, and instead says “capture” at the top when you select the device.

*I have disabled my motherboard’s onboard sound via the BIOS. Even still, Ubuntu had drivers installed for it. I thought they might be interfering so I even blacklisted them. Didn’t work

*I read a lot of stuff saying Pulseaudio causes a lot of problems. So I uninstalled it completely (also while my onboard sound was blacklisted)

None of this stuff helped. Still getting no levels on the mixer, nothing coming into Audacity.

:( Think I’m going to have to settle for my onboard line in for the moment, until I can get this fixed. Assuming I can even get it to work either.

Any input/help is appreciated.


This thread about configuring Jack for Ubuntu (where they use the M-Audio Delta-44 for the case) mention something about “all inputs being down by default”:


Which means not being muted, but just the amplify faders were set to null, are you sure all the ADC’s are up?.


!!! :)

4 hours of waste, fixed by a simple 1 minute check. I wasn’t aware of that program. For some reason Envy24 doesn’t have faders for those.

But yes, it works now.

Thank you so much :)