[Solved] Linux: High Renoise Idle Cpu Usage

When I run Renoise 2.7.2 from Xubuntu 11.04 livecd (Both tried 32bit and 64 bit versions) the idle cpu usage is around 10%. I use Xubuntu on my new Sony Vaio VPCEC4L1E laptop (Core i3) In the preferences there are 4 cores?!!. The Core i3 processor only have 2 cores. In Windows I only see 2 cores, in Xubuntu 4 cores. When I switch from 4 cores to 1 core the idle cpu usage is around 3%, which is nearly the same as in Windows 7.

My question is why Renoise under Xubuntu recognize 4 cores instead of 2 and why the cpu usage is so high.

I use the livecd because I wanted to see how Renoise would perform before I will install it to my laptop. Is the performance problem present because I run everything from the livecd? I can play very demanding songs without any playback problems though.

The settings I used in Renoise were:
only output selected, input is set to none
PAM enabled
64 buffer
3 periods

Does it has HyperThreading technology? In that case each core may have two HT cores and Xubuntu representing these as two virtual cores per core instead of two main cores. (2x2 = 4)
Perhaps turning off HT in the BIOS would resolve the problem (If you are able to). The problem you address is the famous known “HT doesn’t do proper CPU utilisation for audio apps”
If turning of HT resolves it, it would prove HT technology still sucks for audio processes.

Thanks Vincent, I will check it out and post my results later.

I thought when you are running Windows the HyperThreading will be disabled automatically? Is it possible then to automatically disable HyperThreading on Linux too? Perhaps also on OSX?

The VAIO laptop has indeed a HT processor (Core i3). In the BIOS I only could en/disable the C3/C6 CPU support. This option is only for saving energy when the CPU is idle, right? Sadly, there is no HT option in the BIOS.

That was only really true for the Hyper Threading used in the old Pentium4 processors, strange Intel decided to use the same name for a different technology in the new CPUs. There are plenty of benchmarks out there showing that in most DAWs having HT on with an i7 (possible i5 and i3 too) does increase available power.

Although maybe not for Renoise or maybe the i3 works slightly different to the i7 so still worth testing on your own setup.

It could as well be the low buffer settings and the low periods settings that cause a strain on the cpu.
You can also disable two of the four cpu’s in the Options -> Multicore/CPU support title menu.

If you only want to use 2 cores, threads on this system, you can simply choose 2 instead of 4 CPUs in Renoise. This should have about the same effect.

Regarding the high idle usage in general: Maybe its only a display problem. Please make also sure that energy saving is disabled. We can’t calculate the real audio CPU usage on throttled CPU’s at the moment. But on the other hand this only is a display issue, so it doesn’t really hurt.

Thanks Eduard for your reply. I will test with 2 cores and disable the energy saving. Will post my results.

When I set the cpus to 2 instead of 4 and the buffer to 128 and 3 periods, the idle cpu usage is around 3 percent which is fine.