[solved] Linux - MP3 - mpg123


i have downloaded the demo-version of renoise for my ubunut 12.04 linux system.

at the moment i am not able to import mp3-files into renoise. i found out, that it could be fixed with installing and configuring mpg123 in the right way. but i have not found any tutorial about it.

because i am interested in purchasing the full-version, i am wondering if somebody has an idea how to get mp3-versions running on renoise?

thank you very much

just install libmpg123 (or libmpg123-0 as it appears to be on ubuntu) from ubuntu software center, or with this command: sudo apt-get install libmpg123-0

no need to configure anything after that, just re-launch renoise and mp3s should work.

mpeg licensing issues… :confused:

yes, this was also my first intention. i did it in that way.

after the installation i tried to open the mp3-file through “file–>open song”. but renoise is still not able to support mp3-files.

did i miss something? :(

Pretty sure Renoise does not play MP3 as songs. It plays xrns files as songs, and songs can contain samples that are mp3 files.

ha, that would be the day… Renoise imports a .mp3 as a song and auto-detects all the notes, extracts/creates all the samples, puts notes in separate channels, etc etc…!!!

You must load an MP3 as a sample, not a song.

oh, yes - that makes sense. thank you very much. now i can find my desired song.

but if i would like to import it, i get the message: “libmpg123 was not found but must be installed to load MP3-files”.

if i go to my terminal and say “apt-get install libmpg123” i get the message that i am using the newest version of libmpg123 and i dont need to install it again.

now i am confused…

Are you using Renoise 32-bit or 64-bit?

thank you very much for the hint!

i am using the 64-bit ubuntu operating system. if you are using the 64-bit ubuntu, you need to install “ia32-libs” instead of “libmpg123”.

now it works :D

are you using 32bit renoise oni 64bit OS? That’s the only reason i can think of why you’d need that.
you shouldn’t need ia32-libs if you’re using 64bit renoise.

yes, i made a mistake and was using a 32-bit renoise on a 64-bit system.