[Solved] Midi Controller Recognized But No Inputs.

I have a Korg Kontrol 49 I love but I recently tried to use it with Renoise to no avail. I was hyped about using Duplex with it but for some reason it doesn’t receive any notes or cues from the encoders and whatnot.

Have tried the typical stuff (drivers etc) but I don’t know why it works on other applications except Renoise.

Any help would be great.

If you want to try Duplex, most important thing is that you do not select your korg device (or midi device) as an input device in the Renoise Midi preferences.
Set both input devices A & B to “None” and then try to use the midi-in device where your Korg is connected to again in Duplex.

That’s not true. If a device is used by Duplex !and! as master-keyboard in Renoise or something else, they both will play, use the notes/MIDI individually…


Drag Lines:

If you do set up your device in Renoises preferences as Master keyboard, does it work then?

If it does, then the problem is in Duplex. Duplex has its own MIDI configuration, so please make sure you’ve set up the Korg Kontrol 49 there.

  • “Tools” -> “Duplex” -> Browser …
  • Select “Korg Kontrol 49”.
  • Then click on “Settings”.

Are the MIDI inputs correctly set up there?

Perhaps this has been fixed in duplex in the meantime then (i refered to an explicit remark in the duplex manual stating the desired midi-in device should be unselected in the midi preferences), but my own midi scripts don’t respond if my midi-in device is set in the preferences, i really have to clear it or select a different one i don’t want to use with my midi script, else i can’t use my midi keyboard in my scripts.

Very strange. I was able to get it to work (mostly) using the device “KORG… PORT A” which, last time I checked, was the input on the back of the board. I could be mistaken, it’s been a while since I looked at the manual. There is also “PORT B” which does not work.

Thanks for the help. And for the record taktik seems to be correct. I did have it set up under preferences, tried changing it and it worked there, was able to get it working in Duplex with both areas set to the “PORT A” variant, or none under pref and and Duplex only under Duplex setting. (No MIDI)

Note, this was after I updated the driver. I tried the “A” input before I updated and it did not work, strange that it does now.

Pads do not work correctly but I believe this is an issue with the keyboard’s setup, for now the issue is solved. Thanks!