[Solved] MIDI notes not reaching external synths

Ok, here’s another one.

Got some of my synths hooked up in Renoise. Followed the manual step by step, routing the inputs of the synths back into renoise, lineinret.

Most of the time when playing a pattern from the top, all midi notes work and are received by my synths, however, when the pattern loops, it randomly “drops” notes. The notes are listed when I watch the MIDI tab, but they aren’t triggering my synths. Generally, if I stop playback and restart they’ll play just fine… Generally.

All drivers to my MOTU midi express XT are updated… I’m probably just missing something.

I’m loving renoise, just need to iron out the issues that have been plaguing me! Thanks for any help!

Are you sending note-offs ( caps lock ) ?

Are you sending note-offs ( caps lock ) ?


I’m starting to think it has more to do with a latency issue. If I set Renoise as master clock, output to all outs on MidiXt and hook up a synth with a arpeggio, the synth is getting the clock message and the arpeggio plays at the prescribed BPM… but after a few loops it gets off and won’t retrigger at the beginning of the next repeat.

I’ve tried messing with the latencies and haven’t been able to make an appreciable improvement.

Just to verify: you’re running the most recent version of Renoise (3.1.1) ?

There used to be issues with MIDI plugins that could occasionally drop notes - especially when playing a looped pattern.

Also, what is the platform/OS?

If everything else fails, you could drop me a PM with a link to the project so we could take a look.

Yeah, it’s 3.1.1, I just purchased it last week.

I’m running it on a new build, Intel 8700k, 16gb RAM, WIN10. I spent a fair amount of time last night fiddling and still am losing notes sometimes. Sometimes even notes in the middle of a pattern.

Thanks for offering help, what should I do now?

So the problem is twofold: BPM getting “off” when looping, and the occasional note being dropped?

Are you doing anything just remotely advanced in the song, like using a phrase or anything?

You mention an arpeggio, but I’m not sure if that’s a hardware feature on the synth or something you’ve programmed in Renoise.

Right now, I’ve been testing MIDI features with three different VOLCAs (kick, FM and Keys) and a DSI Mopho. (Just the tiny synths for now!) The Mopho has many many sequenced patterns as presets. So I pull up a preset sequenced pattern on the Mopho, say, RASP Bass line, a 16 step pattern.

Now, back in Renoise, I have my Mopho set on a track, set bpm to 150, LPB set to 8 and total lines set to 256. I toss a C4 at the top of the pattern and some other note halfway through. I use note offs.

Now, if I leave it just like this, add no other instruments and play the renoise pattern on repeat, it does ok, but eventually you hear the synth stutter, then when it stutters bad, it will sometimes miss the note at the top of the pattern. If I start adding more ext synth tracks, it seems to exacerbate the situation. When playing poly on the VOLCA FM, it tends to lose random notes in playback. Even in the middle of a pattern. Sending multiple CCs (like mod wheel, or pitch) also SEEMS to make the stutter of the Mopho sequence more immediate, resulting in the Mopho missing the top pattern note.

I hope this all makes sense.

You see, I’m a pretty dumb guy when it comes to computers. This is my first DAW/computer experience. I got tired of programming and slicing samples on old Akais and recording on tape, or all in one machines. I have no idea what LTC, or LTC Quicklock or MTC is. I still don’t know what they stand for, but I now know that switching from LTC Quicklock to MTC in MOTUs Clockworks seems to have fixed my issue.

Thanks for the attention given!

switching from LTC Quicklock to MTC in MOTUs Clockworks seems to have fixed my issue.

Great - thanks for sharing that bit of information. Could possibly help someone else?

MTC stands for Midi Time Code. And apparently, you can control how the MOTU responds to this - very cool :slight_smile: