[Solved] Note-End Only Added When Capslock Turns On.


A note-off is only added when the capslock turns on, not when I turn it off. This means I have to hit the key twice every time I want to add a note-off event.

First I thought my old keyboard was broken, a sticky key or something. I bought a new keyboard, just a simple logitech, but the problem is still the same. Then i noticed I always have to push the button twice and it only adds a note-end when my capslock light turns green.

I didn’t have this problem till 4 months, maybe a little longer. I started using Windows7 about a half year ago, maybe that’s the problem.

What am I doing wrong?


I have the same issue with Windows Vista on my notebook. with the same notebook, I don’t have this problem with Linux.

When I noticed this it was during 2.1 Alpha testing; taktik replied that this is nothing he could fix because it is a keyboard driver problem. He told me that from the special logs he created to analyze the issue, it resulted that I had some strange keyboard layout, something like my keyboard hardware was suited for korean language, while it looks like an italian keyboard.

I rarely use Vista on my notebook so I ended almost ignoring the issue, anyway I solved it by using a software which remaps keys (can’t remember the name, but there are lots available): I assigned Note Off to another key in Renoise, then assigned CAPS LOCK to this key in the keyboard software.

Windows 7 gave me the same issue with my microsoft keyboard here (if relevant?)

Ended up re-assigning note-off to [`]

Got used to it but It-Aliens solution sounds useful if you don`t want to change…

I don’t think it’s because of the keyboard itself, but it’s a problem with Vista in combination with the keyboard. I used two whole different keyboards, both had the same problem. But my old keyboard didn’t have that problem in XP, I’m pretty sure the problem started after I moved over to Windows 7.

While typing this I figure that a combination of os and keyboard get’s to the driver. Then I guess more people will run into this problem in the near future.

I had the same problem with Win 7 and Renoise 2.5 beta something, some time ago… I plugged another keyboard (the one i had plugged was a “mini keyboard” (layout a bitlike a laptop one)) and rebooted, and hadn’t had the problem after that… it worked okay, but then, i’m not sure I used Renoise since that session.

I’ll try plugging one keyboard then the other… strange thing, is, the Renoise worked normally with the first keyboard until this “bug” …

Thanks for the workaround, I installed a key remapper, and my capslock is back in business. Joechei!

I plugged again the other keyboard that has a weird layout (mini keyboard style) works okay. If I understood correctly it’s the driver that could bug sometimes?

It’s not realy solved is it? I can live with the workaround though.

It is not really a problem caused by Renoise in the first place.
Windows Vista and Windows 7 work with DirectX 10 i believe, the keyboard controls might work a tad bit different in that version, but i have no idea if you can support DirectX 9 and DirectX 10 simultaneously without breaking one or another.
For what it is worth, usually Dx 10 should be downwards compatible which means that if it ain’t, there probably was a serious issue with the controller driver in Dx 9.