[Solved] Ntdll.dll Ntalpcsendwaitreceiveport Error On Startup

Hi,

Just recently I’ve started to get an error when starting Renoise. The program loads fine when ok is clicked so it’s more of an annoyance than a problem but it happens on both of my machines.

I have removed the VST folder and the issue remains, the newer version of Renoise (2.72, which I’m not interested in using) load without issue.

It could have been a Windows update that started this, who knows. Google doesn’t yield any info. Any suggestion in to why this happens would be appreciated.

Renoise 1.91 on Win XP SP3 (Both machines are clean according to Kaspersky and Bullguard)

Thanks.

NtALPCSendWaitReceivePort is a function inide the NT.dll but this is for windows Vista or Windows 7.
Even though Kaspersky and bullguard say your machines are clean, there may be something not correct with your kernel files.

You can open a command prompt and execute a “SFC /SCANNOW” option and then restart your system to see if your kernel files have restored to what they supposed to be (and also restart Renoise).
At least i can’t imagine Renoise 1.91 not being compatible with Windows XP and Renoise 2.7.2 is compatible.
Frankly, for what purpose would you like to use renoise 1.9.1?

Thanks for the reply. I have just run the sfc /scanall and it didn’t find any abnormalities.

Renoise 1.9.1 still works, but the error message is annoying. I have re installed Renoise and this didn’t fix the problem either. :(

There was no real reason for not upgrading but as 1.9.1 does everything I want and more I couldn’t be bothered with the hassle of adjusting to the new layout. The mouse scroll wheel behaves differently too which is really annoying.

The errormessage is quite strange because it refers to the advanced local procedure call not existing in Windows XP. Another thing is that it relates to networking which Renoise 1.9.1 for sure doesn’t use, so something is fishy here and i doubt Renoise itself is the origin.

Hey guys,

Since a couple of days I have the exact same error. But I have it when opening FL Studio 10 (sorry for that…)
I get the error around six times, while FL starts up. After that everything seems to work normal, until I try to load a plugin for instance, the error pops up again.

I tried the SFC /SCANNOW, cleaning up the registry, virus-scanning, re-installing FL Studio, but nothing helped.

Oh, and I also replaced the ntdll.dll file with the original from my XP-cd, but that didn’t help either…

Would love to hear if you guys had some solution or if I can be of any help.

Thanks

The only thing i can see confirmed here, is that this issue is Windows related and not Renoise related.
I really suspect some kind of virus or malware here. That anti-virus applications don’t ring any alarm-bells doesn’t mean that you’re home safe.
And i think that Firewalls won’t be able to intercept because the routine is miserably interpreting the wrong platform environment so failing to work in the first case.

Windows can also spit out strange error messages without malware or viruses involved. This will be a plugin or audio/MIDI driver issue (do you guys have installed ASIO 4 ALL?) which was built for Windows 7 or later, thus it can’t run on older versions of windows. Indeed hard to find out what exactly (which plugin or driver) causes this though - sorry.

No ASIO for all here. I run Renoise direct sound so I can have 2 instances running simultaneously. In the last few months nothing has updated the machine except Windows update. I have rolled the machine back to May and the issue had gone.

Obviously cannot rule out malware, when I have a bit of free time I’ll reinstall all of the Windows updates and see if it returns.

Edit. just to add, the issue was also present with NI Massive.

Thanks vV and tiktak for helping out, you both could be right.

I do run Asio4all, but never had a problem with it… I also have a midi-keyboard (already tried reinstalling Asio4all and midi-drivers.
I can’t remember what I updated or installed around the time the error started, so that leaves me in the dark to what the cause could be.
(also, unfortunately system-restore didn’t work for me)

Microsoft says this about the error:
2279 error2.JPG

But what driver… :slight_smile:

EDIT:

I just found this on another forum:

“I get a “FL.exe - entry point not found Ntalpcsendwaitreceivepoint not found in ntdll.dll” message when i open FL, add synths and various other operations. Everything works, I only get this message that i have to click every time. I uninstalled, reinstalled cleaned registry. used system restore… I started getting this message after I installed samsung kies for mobile and it installed some codecs for video with it.”

I installed Samsung Kies (plus codecs “MyFreeCodec 1.0b”) as well around the time the error started!

I just uninstalled Kies and the codec, but it didn’t help. While it’s probably the cause, the damage seems already done… Any tips?

Thanks for the info, I can confirm that I’ve had Kies on both my machines. On the laptop it wasn’t even used, just semi installed to get the USB phone drivers.

Hi guys - I had this stupid problem myself today.

FL Studio just wouldn’t work.

I was asked to put some MP3s on my friend’s sister’s Samsung Mobile.

I downloaded the driver (82meg) and it installed this Samsung Kies software. This IS the problem.

Uninstalling it does nothing…you simply need to perform a System Restore - scroll down the list until you get to the point where you “Installed Samsung…”

Roll back to that time + date and your problem will go away!

FL Studio works perfectly again.

I am angry because I nearly lost my music making computer through this!

Samsung should be accountable for this crap!

ALSO -> Notice how when you Google for a solution - you get all this SEO optimized crap with articles telling you “how to fix ntldll.dll errors”, etc…which just have links to suspicious software packages…exe files such as “RegistryFix.exe” “NTLLDLL.DLL Fixer.exe” and so on!

Grrr!

System Restore is the only way to beat the problem whilst keeping your hair!!!

Ok, so I’ve found a work-around! :)
At least if you don’t want to reinstall Windows or use the System Restore feature!

I found this (and other) pages when trying to Google for a solution, but couldn’t find anything… so now that I found a work-around I thought it was my “duty” to register here and share it. ;)

The problem seems to be caused by the avrt.dll that Kies put in the Windows\System32 folder.
Simply renaming the file stopped the annoying pop-ups to appear all the time. Worked for me at least in Windows XP SP3.

Again, not the perfect solution but a decent work-around.

// Ragamuffa

Ragamuffa, hi,

Renaming avrt.dll did the trick for me. Didn’t even have to uninstall that pesky Samsung Kies piece of garbage (which I only installed to be able to download pics onto my wife’s phone). I will, of course, have to remember to rename it again to run Kies.

Thanks, that was so useful! And I don’t have anything to do with Renoise. In fact, I’m using Mixcraft 5, but just happened upon this site while I was Googling for a solution to the problem. So as a professional courtesy… I signed up to this forum just to let you know how helpful you guys were :slight_smile: So much cr#p up there on the web, very rarely do you find a solution to your problem :-\

All the best,
MetzO’Magic

Ragamuffa thanks a lot!
I was in trouble, tryed solved this problem, but don’t worked…
I was thinking in leaving to use FL Studio because of this problem, but now i have my peace back.

“May the force be with you.”
eco221

Hi I see this is an old issue, but fortunately it worked for me too… In my case the ‘bleep’ message was appearing each time I started Skype. The file renaming works. THX Ragamuffa! I also registered here just to post this greeting :wink: