[Solved] Omnisphere Not Working With Renoise X64??

Hi. I’ve just upgraded my machine to Windows 7 x64. I downloaded the latest Renoise x64 version and I have most of my plugins working fine but I cannot get Omnisphere to work.

If I add an instance of Omnisphere within Renoise, it displays the authorisation screen for the plugin. The problem is worse because it won’t give me a challenge code so I can’t even go and re-register it. (I have completely uninstalled and reinstalled Omnisphere over the past few days and tried both Sandbox option on and off).

However… if I run Cubase, Omnisphere runs, I authenticated it without problem and now it runs every time with Cubase and doesn’t ask for the authorisation code.

So… why would Renoise causee it to ask for the authorisation code?

Is there any debug information I can send to the Renoise team that could assist me with my problem, please? I’ve had a quick look at the Renoise log but it doesn’t show any references to Omnisphere.dll at all. Perhaps there are some additional debug options that need to be enabled first?

Omnisphere did of course work fine when I had WinXP installed - this has only happened since I moved to Windows 7 x64.


Yay!! I figured it out… For some reason I had to run Renoise with “Run as Administrator” and then it allowed me to authorise the application.

Windows 7 strikes again… all sorted and working fine! :slight_smile: