[solved] Osx: Issue With Prehearing Long Samples (Mp3s?)

i’m loving renoise, but i’m running into an issue when prehearing longer samples in renoise 2.1.0 on osx. the steps to reproduce it are:

  1. click on a long sample in the disk browser (not sure exactly how long it needs to be… smashing pumpkins - 17 did it for me just now, that’s about 18 seconds long)
  2. stop playback by playing esc or space, or just let it play to the end
  3. notice main meters are stuck
  4. try to start pattern playback using space or the play button

result: stuck meters, and i can’t play back the pattern. prehearing continues to work for the long sample, but i can’t play anything else.

luckily, i can still save and quit. i’m not sure if i’ve seen this with .wav files, but it definitely happens with .mp3 and .m4a files. system specs attached, let me know if you need more info or if there’s a workaround.

thanks for making such a great piece of software! :yeah:


are those large samples MP3 files? Probably Quicktime, which we are using for Mp3s, is crashing while it finished reading the files. Does this happen with any mp3s for you? Does Quicktime else work as expected on your setup? Which Quicktime version have you installed?
You could try if updating Quicktime solves this problem…

yeah, this seems to just be an issue with mp3 and m4a files, not necessarily long ones. i wouldn’t be surprised if there was an issue with coreaudio or the quicktime api, but other quicktime apps are working fine on my system. i have the latest quicktime, 7.6.2.

today i tried loading an mp3 sample, and found that i couldn’t play/record it… until i clicked on the sample to prehear it. the notes i had attempted to record all appeared at once as soon as i clicked the sample in the disk browser. but then i couldn’t play back the pattern…

Thanks mike.

Anyone out there who has the same problem with AACs or MP3s on OSX?

OSX 10.4.11
Model: Mac firewire 800 mirrored drive door (MMD)

I did 1 - 4 and didn’t have problems with meter and playback. I loaded a sketched 17.7mb xrns (edit: all samples, no vst’s, using native effects) and played a few mp3’s and m4a, (edit: then played what I programmed in Renoise)

On occasion, I use Renoise over itunes to play other music, so i don’t have to open up itunes when taking a break programming or recording in Renoise.

problem solved! switching the output device from “Apple Inc.: builtin” to “Apple Inc. Built-in Output” (or any other interface) fixed it. silly composite audio device…

now i can keep my ears fresh without opening itunes! woohoo! thanks!

Thanks for finding this out. I can replicate this here as well with an “aggregate device” as default output and will try to see if theres something we can do to avoid/fix this…

EDIT: Another way to avoid this, is using the aggregate device in Renoise as well as default output. Then it won’t freeze. Also reinitializing audio in Renoises preferences will bring back the sound.

This looks like a quicktime / core audio bug to me. I’ll contact Apple and ask them for help…

interesting… i’m glad you were able to reproduce this and find a workaround!

hopefully radar isn’t too full of snow leopard bugs ;)

thanks taktik!!