[Solved] OsX: Renoise ReWire Slave to Logic Pro X

I’ve tried to rewire the latest versions of Renoise and Logic Pro but I’m having some problems. There’s no pop-up window asking if I want to rewire Renoise.

First I expected it to be that I installed the 32-bit version of Renoise while Logic Pro is 64-bit, but I removed the 32-bit version of Renoise and just installed the 64-bit version.
I’ve also tried to reboot, delete the rewire-file from the Propellerhead dir and restarted the programs.
I’m getting some info from Logic Pro sometimes though (not every time), it says “Now 4 outputs and 1 input are available” and when I close Renoise it sometimes says “0 inputs” or something like that…

This worked like a charm before with previous versions of both programs (on another computer), so what am I missing?


Well I’m not sure though, :unsure:/> (since I’m not a Mac user)

I’ve seen a similar issue about ReWire between Logic X and Renoise 3 in japanese anonymous forum.
And after all, the problem was solved by installing the demo version of Reason 7 (at least the user said so).

Honestly, I do not understand the cause of the problem at all though… maybe worth trying.

Problem solved by installing Reason 7 demo?!
That sounds wierd, but I’ll give this a try and report later.

Ok, Reason 7 installed but Renoise Rewire still doesn’t work with Logic!

Hmm sorry, then I also don’t know how to solve your problem unfortunately.

Btw; now can you use ReWire between Logic and Reason 7 ? Only Renoise doesn’t work?

I don’t know how Reason works but there’s no pop up there when I start that program iether, so perhaps it’s a Logic Pro problem?

Ok I solved it!

Logic Pro X had default OFF for ReWire in the preferences. :)

Ok I solved it!

Logic Pro X had default OFF for ReWire in the preferences. smile.gif

Soon two years later and I have the same problem!

Logic Pro X has ”ReWire Behaviour” set to ”Off” and I launch Logic Pro before launching Renoise (version 2.8.2). Still don’t get the ”Run as ReWire slave” dialog in Renoise. Both apps are 64-bit versions.

Any ideas?