[solved] Plugsound VST Won't Load (crash on dll scan)

Hi all,

I know this is an old plugin, but I’m in the process of remastering some of my old tracks and was hoping to get the original Plugsound Volumes 1 through 6 up and running again. I have the software disks, but when I put the dll and dat files into my vst folder, Renoise hangs upon scanning the first dll (keyboards). If I click the splash screen during the hang, Renoise will crash and I will get an error sayingplugsound could not find an authorization (I can’t even get to the authorization screen since it usually pops up when you first initialize the plugin in a song).

Renoise adds them to the crashed plugin cache and will boot normally when opened again, but without scanning the plugins. I tried clearing the cache and running as administrator, but to no avail… I read somewhere about the possibility of there being a registry conflict with another VST - is that a thing?

Anyway, I know it’s a long shot, but if anyone out there is still using this software or has any info to share on compatibility with old 32-bit vst plugins, I would appreciate any pointers. Thanks!


I was able to solve this issue for anyone that may encounter this same problem with old versions of Plugsound (or another 32-bit VST).

The solution is to install the 32-bit version of Renoise AND run it as administrator. The plugin won’t crash on startup anymore and the activation screen works fine (only if you run as administrator - the activation will not work right otherwise).

The 64-bit version of Renoise will now load the plugin properly once it is activated, so even though you need to use the 32-bit version to run the activation, you can go back to using the 64-bit version.

Hopefully if there are other 32-bit plugins out there that crash on startup, this solution might work for those as well!