[Solved] QuNexus Hiccups, Lags, Double Notes while Recording

yeah, the QuNexus is incredibly expressive. I LOVE its sound. It plays find and doesn’t lag, however when I record in Renoise, I notice that the notes don’t record accurately and notes are being registered off tempo and also there is note doubling going on at times as well. I understand it may be a QuNexus issue, but I wanted to know if there is anybody else with a QuNexus who is experiencing the same thing? And if there is any fix for the situation. thanks!

You could raise your LPB or toggle the Q(uantize) box or do both.

One thing that took me way too long to realize was to turn off freaking auto save during playback. This would always happen as I was playing and make lag/timing go to shit. It should really be disabled by default imo (at least during recording).

thank you i’ll try that, I had a theory that maybe the q-nexus is sending too much information or not sending information effeciently enough maybe and it causes lag spikes.

Hmmm - the device is playing fine, until you turn on recording?
That sounds like a Renoise issue to me.

Have you got any scripts installed that might also act on these MIDI data? If so, try turning them off.

It’s true that some devices have a much higher update frequency, testing with some plain old MIDI keys might reveal if this is the case.

I did some tests, first I went into renoise midi options and removed all the checks from polyphony and pitch bend etc leaving only velocities and note offs checked. The recording tests I did seem to run smoother and without lag under those conditions. Then rechecked all the boxes and went inside of the QuNexus Editor that allows you to configure the controller and I turned up the resolution on how it registers pitch bend info from the default of 2 all the way up to 8 which means that it now is sending information about 8 key tilt positions from EACH of its keys.

Doing so increased the lag so much that the frame rate inside was reduced to a crawl, muuuuch more lag than before.

It seems that the QuNexus’ habit of sending pitch bend information for each key might be causing lag as opposed to say the M-Audio 88ES which only sends pitch info from the pitch wheel.

Hopefully there is some configuration that can smooth things out because it is the aftertouch + all the pitch bend information that gives the QuNexus such a great quality sound when playing guitar and synth VST for example and that’s why I’d like to be able to keep the pitch bend per key running while recording.

The only script/tool that I run is the TempoTap pad.

I’ll let you know if I figure something out. thanks for the support!

Although I can see creative uses for all of this information, isn’t the pitch-bend information going to waste then? I’ve never encountered a soft-synth which had multitimbral pitchbend, only a single global one.
Regardless, the QuNexus does seem to choke Renoise with all those messages

Sometimes, the audio card / driver latency can also have a say in these matters. I’m not sure what your particular setup is like, but I’d say that it’s worth trying to adjust the latency and see if that changes anything.
Otherwise, I guess your only option is to strike the right balance between precision and responsiveness, using the MIDI preferences and QuNexus editor, as you already pointed out.

PS: What is your music machine / setup like? Renoise version, CPU, operating system…

I suppose they are building the hardware so that they can make it possible for software to follow suite if a programmer wants to introduce that into their program, I guess. I bought it ahead of time knowing that currently all the software I know of only takes one pitch value while recording. It’s good for guitar VST because whenever your finger fails to hit the exact center of the key, you get a nice subtle pitch bend - then you can program your VST to add effects if you do a pitch bend while pressing the key with a high velocity

My machine is a I5 2.67ghz // 16GB RAM// Renoise 2.8.0 // Windows 8 64bit // SoundCard is Claro Halo XT

I have an M-Audio 88ES, a Shure instrument mic + Scarlett 2i2, and the QuNexus

Indeed, and that together with the CV in/outs makes the QuNexus a very unique thing :slight_smile:

As for your computer specs, that CPU certainly should be sufficient. Such a relative simple as MIDI messages really shouldn’t bring Renoise to it’s knees, but it certainly looks that way.
The only other case where I’ve experienced a particular unit that caused problems due to the high frequency/volume of traffic was the nanoKontrol2. But even then, it didn’t cause such serious problems.

Hi guys,
My name is Diane and I’m a software developer at Keith McMillen Instruments (as well as a Renoise user!)

First off, I just wanted to make sure you are on the most recent version of the QuNexus Editor and firmware. We just recently uploaded version 1.1.1 and it has a lot of new features and improvements which may fix your problem. Here is the link to our downloads page:


In the meantime, I will test to see if I can reproduce and fix your problem.

I also just wanted to clarify how we are able to do polyphonic pitchbend in case there was any confusion. QuNexus can use a mode we have called Channel Rotation which allows each key to send pressure and pitchbend data on a different midi channel. If you set up multiple instances your synth so that each one can receive on a different midi channels then you can create the effect of polyphonic pitchbend as well as aftertouch. If you have this mode activated, then when you press one key, all its midi cc and bend data goes out channel 1 (or whatever your base channel is set to on the QuNexus editor). Then while holding down the first note, if you play a second note all of its data goes out channel 2. A third note will send out channel 3. But if you then release these 3 notes and play a new note, it goes back to channel 1.

As far as I know Renoise should be able to record the extra data without a problem. I’ll check it out.


Hi again,
I’m afraid I have not been able to reproduce your problem yet. I was wondering if there is a particular instrument or VST which is not working with QuNexus? Perhaps you could post a Renoise song file which has been giving you trouble, and the QuNexus preset you are using? You can get the preset file by going into the QuNexus editor, selecting the preset in the Library, then going into the file menu and selecting “Export Preset.”

hello dianed! across time and space QuNexus support to the rescue! As well as everyone else, I did some tinkering at which point I managed to make it so the QuNexus didn’t work at all with Renoise. Then I did some more tinkering and applied all the suggestions I had gotten on the forum and now it seems to work perfectly with no lag knock on wood - I had already updated to Editor 1.1.1 so I didn’t have to change that. But I did change the following things:

I enabled polyphonic channel rotation in QuNexus Editor
I disabled autosave while playing in Renoise
increased latency from 42–>50 in Renoise

and changed my settings to what you can see in the pictures I’ve included that I uploaded just now - before it really was slowing Renoise down. The VST I was using was Acoustic Legends HD, but I don’t think it was related to the VST. It got extremely choppy when I increased the pitch bend range in the QuNexus editor which strangely enough doesn’t seem to be slowing it down anymore

It’s not a general midi problem because I’ve never had any issue with my M-Audio88ES, so maybe I just clicked a wrong button somewhere. Maybe it was the save while playing option or the latency or some perfect storm of variables that I don’t know about yet. But at one point it was really having its issues. But now it’s not =)

again thanks everyone for the advice and support. Though I don’t understand what caused this I will declare it ‘fixed’. I’m ready to move on if I can =p, but if you need me to do some bug tests I can do some of that too - btw I attached my new working preset, I renamed it to a .zip even though it actually isn’t zipped.

Hey, that’s great! So glad to hear it’s working now, and thanks for posting the screenshots and everything!