[Solved] Renoise 2.1 & Synful Orchestra Vst

Hey guys,

Long time no see…

I’ve recently started up my music hobby again and have been working on a new track which I’ll link to shortly.
I’m running Renoise 2.1 (I can upgrade to 2.2 with my current license but might just upgrade to 2.7 anyway) and am having serious issues with a VST called “Synful Orchestra”.
The sounds this VST can create are nothing short of a miracle, however without the masking done by a drum beat and other sounds, it has occasional audible pops and clicks.
I’ve switched to using ASIO4All drivers (was using DirectX) and this seems to have helped reduce the amount of artifacts but they are still present.

It sounds like when the CPU is overloaded, but I’m at around 17-20% CPU average so it’s not that (AMD PhenomII X4 955).
I’ve played with latency/sample size settings but this hasn’t really helped - any ideas?

Finally, have there been any bugfixes regarding VSTs between 2.1 and 2.7 which may explain this issue?

And now for a video:

Thanks all :)

A single track, and I believe many VSTs, can only be processed on a single core. So pushing 20% of total could well be getting close to maximum on one core. Have you checked Task Manager while this is happening?

Hi and thanks for the response.
No, it’s not overloading any cores - I just checked and it looks like the attached while playing the song in question.

It’s a shame this artifacts are occurring because it’s making me think twice about purchasing what is otherwise an excellent VST (running it in trial ATM).

2 things i’d consider personally if i’d run into this issue:

  1. upgrade your Renoise - i’m sure there have been some VST fixes over the years (right?)
  2. contact the VST developers to find out if it is possible these artifacts are something that will go away in the full version

i have no idea if these things help, it is just what i’d do. good luck!

When a plugin has crackles/clicks/pops/etc in its output, in many cases this can be solved by forcing it to use static processing buffers. You can find this option in the plugin compatibility settings:

Amazing - this has fixed it!
Thank you! :)

should’ve known with these kinda threads that waiting for what dblue has to say would be the answer.

glad that helped! and nice you have marked it ‘solved’ already, keeping the forums clean.