[Solved] Renoise 2.8.0 + 1616M Asio = No Sound?

Hi, I have a Creative’s EMU 1616m PCIe Audio System, all 64-bit drivers installed running on Win7 Pro x64 with all latest windows updates installed.

In Renoise 2.8.0 > Audio > Device Settings > Device Type: ASIO = NO SOUND
In Renoise 2.8.0 > Audio > Device Settings > Device Type: DirectSound = All OK!

Previous 32-bit versions of Renoise caused no problems. Any advice? Thanks!

win7 + Emu beta drivers - sux

Are you running Renoise 64-bit or Renoise 32-bit?
[s]There could be a few situations the case here:
-64-bit ASIO drivers of your soundcard require a 64-bit host -> Use Renoise 64-bit OR:
-The 64-bit ASIO drivers are frankly upgraded 32-bit drivers (meaning they are still 32-bit but are compiled to run in a 64-bit environment) -> Use Renoise 32-bit.

The fact that DirectSound works is already a good indication that the current bit-version is involved.And the fact you mentioned it worked in previous 32-bit versions indicates to me your ASIO drivers aren’t 64-bit. [/s]Nevertheless i’m not sure whether you were executing the 64-bit or 32-bit version of Renoise so i’m not judging yet here.

Arrghhh I knew this day would come where I regret to have bought a creative/ex-emu product!
Yes I use Renoise 64bit. I have also tried Studio One 64 bit - same result. ASIO in 64 bit hosts=No Sound :(

[s]So I believe what you said about the ASIO drivers is correct, they are not 64-bit. :angry:

Now that was a waste of time but at least we know. Thanks again for your help! [/s]

I don’t know if you have the latest drivers downloaded (they are from July 14th last year:EmuPMX_PCDrv_US_2_30_00.exe).
Perhaps there is a setting in the ASIO panel of your soundcard drivers where you have to check boxes to enable outputs.
http://forum.cockos…ead.php?t=54686
http://forum.djtecht…ead.php?t=13247

Else there is not much other that you can do about it than asking Creative to create true 64-bit ASIO drivers i’m afraid.

Thank you very much for the reaper forum links! I finally made it work after reading this. I just need to add an ASIO channel in patchmix and it works like a charm.

The confusing part is this wasn’t necessary using 32-bit hosts.
Also in Renoise, the option “Limit to stereo in/out” needs to be ticked, otherwise the sound crackles like there was some kind of buffer problem.

So thanks again for pointing into the right direction, you saved me some money buying new gear :w00t: