[Solved] Renoise 2.8 Won't Detect Sonik Synth 2

OS: Windows 7 (64 bit)

Renoise Version: 2.8.0 (64 bit)

IK Multimedia Sonik Synth 2 Version 2.11 (9J14)

This is one of the first times I’ve run into issues with Renoise not detecting a VST plug-in as an instrument. When I re-scan my vst folders, I can clearly see it look over the .dll of Sonik Synth 2, but it will not show up as an option for the Instruments section. I tried searching Google and the forums to see if there was a known conflict with Sonik Synth 2 and Renoise, but I couldn’t find anything topics regarding this issue. I also tried installing Sample Tank 2.5 to see if it could be read within Renoise, yet I run into the same issue.

Is there anything I can do to fix this, or will Sonik Synth 2 just not work with Renoise?

I reckon your answer is below… I erased this… so it would not confuse…



Ahh, I think that it’s a similar problem about Sampletank 2 series.
You should start Renoise with administator rights (i.e. “Run As Admin”) every time.

Well, ST2 engine is an old program now. There is a rumor that ST 3 will be released by the end of this year, but who knows… ;)

Just had some time to try it - it worked! Thank you so much.