[Solved] Renoise As Rewire Master Problem


I’ve been using Renoise for a couple of years, and recently discovered the bliss of Rewire. Yesterday I configured a song with Renoise as master and Reaper as slave with some vocal tracks. This was all fine and dandy, and I was immensly happy with this arrangement.

However, today after a computer reboot, Renoise no longer detects Reaper as a Rewire device. I have taken care to start Renoise first as the only Rewire device, which should automatically make Renoise the master. Even after I start Reaper and add a new Rewire metadevice, Renoise will still not detect it.

Any ideas what I’m doing wrong?

Edit: also, if I now try to start Reaper as Rewire slave (with Renoise already running), I get this:

Edit 2: I reinstalled Renoise, and now Rewire seems to work properly again. Is it fair to assume I will encounter this problem again? :)

I’m having a similar problem. REAPER=Master, RENOISE=Slave.

RENOISE doesn’t appear in REAPER’s list of ReWire devices. With REAPER running, when I try to launch RENOISE, the latter gives me an error message saying it couldn’t initialize ReWire. Then it crashes. Sloppy.

I’ve tried uninstalling and re-installing RENOISE from scratch, without success.

I’m on Windows 7 64-bit, with a 9-month old Sony laptop, admittedly not optimized for music, with 4 GB RAM, processor U7300 1.3 GHz (2 cores).

RENOISE 2.5 didn’t have this problem, and I have REAPER v3.6, 32-bit. DON’T TELL ME TO UPGRADE that other program, I’m sure it’s a RENOISE problem.

Thank you.

Renoise is 32-bit… i don’t know if you use the 32-bit version of Reaper, but i can at least confirm that i can’t use Renoise and 64-bit version of Reaper in any ReWire configuration (Master or slave). I however highly suspect this is a bit architecture problem (You can’t communicate 64-bit language to apps that can only translate 32-bit of it)

Try to start Renoise or Rewire (the master) as administrator. UAC on Windows7 may cause trouble with ReWire.

Also, as VV pointed out, you must use the 32bit version of Reaper if you want to run it as ReWire slave to Renoise (which is 32bit on Windows)

I’ve set both REAPER (32-bit) and RENOISE shortcuts to run with administrator privileges, and it worked! Thank you very much for the tip. :D

Dang, I dislike this operating system which has so many complications…