[Solved] Renoise Does Not Recognize Session Drummer 2

Like said in the Title, Renoise does not recognize the Cakewalk Session Drummer 2 as VST(i). Other hosts do.

by “other hosts” you mean just Sonar or also non-cakewalk sequencers?
I know Session Drummer 3 is a Sonar exclusive product (which won’t run in any other sequencer)

This thread on their forum seems to imply the opposite.

http://forum.cakewalk.com/tm.aspx?high=&m=1860746&mpage=1

EDIT: Although you mention SD3, which is Cakewalk only, and this is SD2. Also can’t find a link to the system requirements myself but it is sold under their Virtual Instruments section on their Shop pages so would of thought it’s a general VST…

Well, even if it is a 10 bucks bargain (because that is what they ask for it today instead of the 75 bucks), i’m not willing to invest 10 bucks just to test this issue.
I could not find a demo of this plugin unfortunately.

By “other hosts” I mean Ableton, Cubase, Reaper and FL Studio. Session Drummer 2 is a pure VST.

So that’s the final respond to a bug report then?

Does it show in the Effects list? That’s an occasional bug and attempting to load as Effect will give a error message, rescanning (maybe after reloading Renoise) and it will start appearing in the correct place.

Could only test it actually in ReNoise 2.7 on win xp (sp3). And here sessiondrummer 2 vst works fine.
Are you shure, that sessiondrummer is installed in the right vst-folder?
Cakewalks installers sometimes place the dlls too in a own cakewalk-(vst)-folder, or builds some hot subfolders. If this is the case, drag the session-drummer.dll in vst-folder you are using for all other vst´s and normally it works. If there is a subfolder, please drag it too in your vst-folder because path-depht (or change .ini).

The session-drummer.dll is located in a subdir of the (32-bit-)VST path I use for all hosts. Strange it shows up for you. But even more strange it doesn’t for me. :D Im running W7 x64, Renoise 2.7.2 btw.

@Kazakore
Already did rescans, reinstallations of the VST and checked the DSPs. Doesn’t show up anywhere.

Edit:
Btw. I also routed the Renoise VST path directly to the SD2 subdir only. The .dll appears for a second in the Renoise footer when the path is scanned, but it doesn’t recognize the VST. Reaper uses the 32-bit bridge to implement the VST, so it’s also not a x64 VST.

Edit 20:29h:
The behavior was reproduced and confirmed by a friend running the same configuration (Win7 x64/Renoise 2.7.2). While he claims the Session Drummer appeared in 2.7.0. I can’t tell if this is (was) really the case.

Edit:
Tested SD2 with Renoise 2.7.0. Doesn’t appear there anywhere. Neither in 2.6.1.

Does this help?

  • Renoise -> Help -> Show the preferences folder.
  • Delete ‘CachedFailedVSTs*.db’ and friends. (Keyword: Failed)
  • Restart Renoise.

No, that is just my personal decision, Taktik or any of the other programmers are the ones that can also look into why the plugin does or doesn’t show up. The only thing i can do is either confirm the problem or not confirm it, but i don’t perform purchases for that.
Perhaps it scanned as a problem plugin, if you check the "Rescan previously failed plugs"and do a rescan, perhaps it then shows up in the list?
When it regards Windows 7 64-bit , i was at first thinking it might be a Windows 64-bit problem. (I have a few other 32-bit plugs that don’t work, but they don’t show up in other hosts either)
But when some confirm the plugin to work in 2.7.0, there might be something corrupted in your VST plugin database.
What if you would rename your Renoise 2.7.2 folder in your user folder and try to rescan from scratch? (or simply rename the scannedVSTs database and failedvsts database cache files so that Renoise has to rescan and rebuild the databases from scratch.)
This also seem to have worked for another user regarding another plugin.

Yes, sessiondrummer is only 32-bit and will never change to 64 bit. But cakewalk tells it WIN 7 compatible (32-bit).

can you test it on a 32-bit win 7 system? For me it runs on XP really again and again definitly fine.

Of course I know it’s only 32bit. I just wanted to prevent the question if its 64bit. :)

Deleting the failed plugins cache and rescanning had no effect. “Rescan previously failed plugins” was activated anyway.

JdS, I don’t doubt a second it’s running on x86 XP. But it doesn’t on Win7 x64 (with Renoise only), while it works with any other tested host/bridge.

Probably a look into the log.txt file can shed a bit of light into this: “Renoise -> Help -> Show Log file…”. Search for the session drummer dll name there.

You may also want to try to start Renoise as administrator, then rescan for plugins, make sure “Rescan previously failed plugins” is activated. Some plugins do need administrator rights to initialize, write their config files correctly.

hi,

could also try to run session drummer installer in an older os compatibility mode, right click installer > properties > compatibility. this worked for me with other ‘older’ plug installers that wouldn’t work otherwise.

I could also imagine some missing runtime installation like VC redistributables and such, which exist in various versions. You could try a tool like http://www.dependencywalker.com/ and look if it’s missing an important DLL file.

Running Renoise as an admin (everytime!) the plugin works indeed. But I’m not going to run it as an admin all the time. Works in other hosts without admin rights, so this still seems to me to be a bug. Anyway, thanks for your efforts.

Sometimes the plugin only needs Renoise to run as admin just to configure a few system settings. After that, you don’t necessarily have to run Renoise as admin.

There are plugins that have a lot worse problems on Windows 7. (East-West’s Play plugin overrules every other aggravating plugin as far as i can tell.)

I explicitly wrote “everytime”. Any idea why? ;)

Obviously there’s something going wrong with Renoise and a few VST, at least on W7 x64. Other hosts don’t have these problems with the same plugins. To mark this thread then as solved, just because the bug reporter decides to use the related plugin in another host, proves at best a strange kind of humor.

Edit: To prevent the next question “Which plugins?”, let me add for myself I am also talking about the Emagic EVP73 and I was told by a friend, Broomstick Bass has the same kinda problems. That’s already 3 having problems with Renoise only. And I’m pretty sure there are more out there.

Yeh it’s strange that sometimes threads get marked as [Solved] when they aren’t really solved, or are solved like half… :s

Well, it could be a communication issue? A lot of different native languages in the forums and everyone agrees to english?

To be completely honest I have no idea. I don’t know who marks threads as [Solved] and I have an @renoise email.

I think it would be appropriate for the person who changes the subject to [Solved] to reply with something like: “Based on [fill in the reason] I have marked the thread as [Solved]. Hope that’s cool.” then people can praise or flame said solver.

As an aside, Renoise has an official support channel. It’s via email. Forums are always quicker, but it’s a community brewha first, support channel second.

Thorns on a rose.