[Solved] Renoise Freezes Trying To Load This Track! (Win7)

I dont know what happened, but this .xrns won’t load… Im using registered 2.5.1 for now til I can afford to update my license. I tried the 2.7 demo, and same story…

I read somewhere on here issues regarding the SideKick vsti, which it just so happens I used in this track.

Is there anything I can do other than LEARN TO BE REDUNDANTLY REPETITIVE IN BACKUPS?

This hasn’t happened before, Ive had tracks corrupted, but that pops a message up telling me so. This however just turns Renoise into a blank white space.

Am I just not waiting long enough? I hope so…

Here’s the file; http://www.mudpeople.lsdxm.com/frangipani.xrns I dont even remember what vsts I used, other than SideKick, but if anyone could even just load the damn thing Id be happy.

Although I have virtually none of the VST effects or instruments you used in this song, I could open it in 2.7.0 and 2.5.1 just fine.

Edit 2:

I am a human of substandard intelligence.

I let it run instead of opening the task and ending process.

Took a while but, I now have it open for business.

Sorry everyone for freaking out about a non-issue and making a thread in the process.

Feel free to lock/delete this with my apologies.