[solved] Sample That Sounds Different Inside A Project

I have a major rns project which I’m working on for two weeks. It’s very big, about 40 channels.
I have a BD sound that I really like and use it quite alot.
When that sound is played inside a track in the project, it sounds blurry, like it lost some of the sound characteristics and is too bassy. I must insist, NO effects are linked to the track. even opening a new track, reloading the sample into a different slot won’t work! still, when I play it it’ll sound blurry.
If I open the sample editor and press the ‘Play Sample’ button, it’ll sound as it should. than, when I press a key on the keyboard to test it, again it sounds blurry.
I opened a new project, loaded the sample into it, and it sounds perfect.
I notice it happened only with this particular sample in the project, or it might be that only with a bassdrum (has lots of low end) it’s possible to notice the problem.
How can I solve it? I can’t start again, it’ll be wicked; those are 10 minutes and a very complex module.
I hope you guys can help or ran into that in the past.

Here’s the file, stripped of all other channels, patterns and instruments, except the kick and one pattern. See it for yourselves, this is weird… :blink:


Spoke on IRC with MickRip and mr_mark_dollin about it.

apparently, there’s a known bug in renoise in which renoise won’t play the first offsets of certain samples. It can be solved by adding a short offset at the beginning of the sample, than it’ll sound correctly.

I suppose that bug should be fixed. here’s an additional file to show you the result with a fixed offset.
there you go taktik :rolleyes:


instead of adding a small offset , you can also use the drawtool to insert a ‘click’ in your kicks. Just zoom in and draw a spike, can have pretty nice results.

Thats not a bug, thats a sideeffect of an Amiga FT2 compatibility settings in the Song Settings pane:
FTII and Protracker do ramp (smooth) all samples to avoid such clicks - so Renoise does when importing old Amiaga MODS or XMs.

Set the “09 Mode” in the “Song Settings” to “Renoise” and Renoise will play the sample exactly as it is…

Thank you for your help. :yeah: