[Solved] to disable midi rec on a track, while recording on others

hi Forum

i wonder if it was possible to disable recording of midi on a chosen track, while recording (midi) on others.


Hi handclap, this is forum speaking.

I have no idea wtf you’re talking about. But as a forum, i appreciate your post. Thank you very much, and have a nice day!

  • Forum.

I assume you have directly connected midi devices to different instruments through the instrument midi in properties and linked each to its own designated track.
In that case, disconnecting your midi device for the specific instrument will do.


thanks for the fast reply!

yes my setup is exactly as you described, but disconnecting midi does not solve the problem.
Let me be more clear on this: im using a hardware sequencer connected via midi to renoise instrument. If I disconnect it there will be no sound. When it’s connected, I try to write some midi on another track on the fly, so I push record and my sequencer pattern is recorded as well. So I thought that there may be a way to disable recording for the chosen track (only playback).

Yeah, that is pretty much a problem, i can understand that.
The only thing that works here is routing your input device outside Renoise with a virtual midi cable.
But a midi-passthrough option has been requested before… i’m not sure where that topic is exactly…

thanks for the reply :)

i guess i just make a “bypass” in pd

another workaround is to run 2 instances: 1 as recorder and 1 as an instrument


how do I mark this post as SOLVED?

It seems you just did ;)