[solved] Uad-1 Problem (plugin buffer mismatch error)


I’ve recently bought an UAD-1 dsp card and some plugins.
I’m having trouble running them on Renoise.

Typical situation is that I’m getting ‘plugin buffer mismatch error=30’ message.
Some it helps to retry loading for a couple of times and plug is working.
But some of UAD plugs won’t load at all in renoise and I’m getting this error message.

Thanks for any suggestions and comments.

I’m running newest version on Renoise and plugs has been legaly bought and registered.


As I understand it from past reading on this forum, DSP cards are not supported by Renoise. Exactly why this is so I don’t know. But I’ve never heard of anyone successfully calling UAD-1 cards or similar from inside Renoise.

It would be interesting to know what the technical issue here is, though. Could Renoise at least in theory support DSP cards?

UAD and other DSP plugs simply require some special settings/setup and also need PDC to be usable. Also we got no support from universal audio so far to get their plugins properly integrated. Let me contact them and ask for help…

But: Reading some other hosts forums, it looks like this “plugin buffer mismatch error=30” means that the UAD expects the host to call the plugins with a specific block size. Our block size is 256 samples by default when the “StaticBuffers” option in the CachedVSTs.xml files is enabled for the plugin.

So if there is somewhere an option to setup the blocksizes for the UAD, try setting it to 256 samples or higher. This could fix the problem…

thank you for suggestions.

i’ve resolve the problem by increasing extra buffer size in UAD’s configuration panel. what’s interesting - adding extra buffers don’t increase the plugins latency but at the same time using higher amount of UAD plugins causes that more motherboard’s CPU is needed.

anyway now I’m happy to work with more than one plugin at a same time;)


Be sure to enable “StaticBuffers” option in the CachedVSTs.xml for all UAD plugins.

Works fine here.

Is there way to change that static buffer block size for renoise?

I could run few tests then…

hello! i’ve just got back into using renoise and just bought the latest one, to find i get this problem too…

i checked the cachedvsts.xml, but its full of plugins i dont own (is it meant to be?), didnt contain any UAD plugs, so i typed in some of the uad plugs i use, changed the static buffers to true, but still get the error?

i can run maybe 2-3 plugs then any after that is the plugin buffer mismatch error

maybe someone could post their cachedvsts.xml?

i dunno/ ?


The cached vsts contains all known plugins that require or not require static buffering (or can run or cannot run on a MULTI-CPU environment).
It does not mean you need to own the plugins or have them, but if you have them, the plugins will be in there.
Since Taktik’s response was not long ago, any particular setting for these plugs may be in the list, but an update of Renoise has not been published which might mean that the plugs are in your cachedVsts.xml but static buffering option is set to false.
If you can access these plugs, they are in the list, you just might not look carefully enough.
I have no clue how these plugs are named, perhaps someone else can give you this clue.

All UAD plugins should have set the correct options in the cache. We do enable these options “by manufacturer” to get all UADs handled.

Thats only one part of the fix though: See my and moltenloves post above. You also have to increase the UADs buffersize (in the UAD preferences!) to make it working.

still cant get this working, could someone upload or paste their cachedvsts.xml please? :(

i never did get this working :(

and i now i got a 2nd card, it really needs sorting.

help me please!!!

Just enable ALL UAD plugin options on Renoise.

Dont have any problems here.

What UAD driver u use?
5.1 or 5.2?

coz in 5.xx you can’t change buffersize! Only in 4.xx driver support this option,

so i never get this problem,
if you have AMD system not Intel thnn chek UAD/controlpanel and

  • click "AMD-8131 Compatible mode! if you have Intel untick
  • Dont change MING_GNT:64
  • chek Limit DSP load to parameter to
  • untik Sonar Compatible mode

and use 5.1 driver or 5.2
and what type of plugin you get this problem,
Neve or ? gimmi the list im chek for you with my UAD1

Big up.