[solved?] Weird glitch with VST plugins and effects


Mac Mini Mid 2011
Processor 2.5 GHz Intel Core i5
Memory 4 GB 1333 MHz DDR3
Software Mac OS X Lion 10.7.5 (11G63)
Echo Audiofire2
Renoise 2.8.0

So, what happens? I play a song for some time with VST instruments or effects and suddenly one of them decides to crash/freeze emitting this sound (EEEeeeeeeeeeEEeeeeeeeeeeeeeeeeee). I have to reload the project-file to get the plugin to work again. This is quite problematic, especially as I was planning to play live with Renoise.

I’ve used Soundtoys Echoboy, Ambience and Albino3, all of which have done the same thing. Could this be something with Renoise or is it just the plugins?

does the Renoise log file say anything about?

Help => Show the Log file

Unfortunately no. Well, nothing related to the plugins anyway. The only thing that looked peculiar was this:

System: Failed to set kernel realtime priority for a thread (error: 4). Current user may not have sufficient privileges to change the priority.

Dunno what that is, but it seems to pop up quite often. Though if that would be the cause for this issue, I think it would’ve happened a lot more frequently.

Here’s the Renoise.log http://pastebin.com/aDQtt32P
Here’s the Renoise Plugin Server.log http://pastebin.com/ES6DexRt

Hopefully that’d help out a bit.

Are you running Renoise 64-bit version or the 32-bit version? I notice an i386 mark, but that does not warrant me this is the 32-bit version.
Considering that the plugin server runs, it looks like you are running the 64-bit version.
Have you tried running the 32-bit version of Renoise? Do the plugins behave the same?

I’m running the Renoise_Reg_32bit version 2.8.1, so yeah it’s 32-bit. For that session I tried if it would help to enabled the “Run all plugins in sandboxes”, I guess that is why it wrote the “Renoise Plugin Server.log”. It didn’t help, the plugins still crashed while in sandboxes the same way they crashed when not in sandboxes.


Hey you all superbly magnificent people who populate this forum: Help me help you.

What more information could I provide to help you guys to find out butt-a-fuk is wrong with the program?

Sounds like something generic is wrong here. It doesn’t seem to be Renoise itself.
You could perhaps browse to the preferences folder (you can find a link to it in the Help menu that opens the finder for you), close Renoise and rename the whole preference folder.
Then restart Renoise and rebuild the plugin database from scratch by relocating the VST and AU plugins path.
If you still get the same problems, i suspect there might be something wrong with the plugin configuration itself so you could try and uninstalling and reinstalling the plugin(s) that are causing the problems.

Okay, thanks for the tip! I’ll try it out today, posting the results here.

So, apparently it didn’t help me to solve the issue, but it did (for some mystic reason) help me to find the culprit. Apparently the Echoboy wasn’t so keen on cooperating with the other instruments and decided to throw random tantrums in the aforementioned manner just like a retarded baby, so I decided to replace it with TAL Dub III. Now we’re a happy bunch of electronic music mayhem.

And thanks for the Renoise dev-team for making an awesome DAW! Luv it!

did you used the Echoboy demo/trial version? Demoplugins likely have this intended behavior (after 30 days or during its all-time use) to persuade you to purchase the plugin.
This behavior can cause a lot of confusion, specially when this behavior is not described on the plugin its vendor pages.