[solved] Where To Put Dsps (AUs/VSTs) on Mac

Hi out there!

Been trying out Renoise last couple of days, really brilliant, pro’bly gonna buy it once money turns in…

Anyway, I’ve been gathering some VSTs, samples, DSPs, including Supaphaser and Crazy Ivan (the free ones, you know ;)).

So far I’ve succeded in implementing all VSTs and samples into my library, but I really haven’t been able to find any info on where to put the DSP plug-ins. I’ve tried all kinds of random folders, but nothing works.

I work on a Mac OSX netbook, so I’ve both tried with the normal archives and the AU ones in all combinations.

This is probably just a very stupid thing that I’ve overlooked, but nontheless it would be great to get an answer.

On beforehand, thanks.

VST-s and AU-s

Check out also the other tutorials. You’ll be amazed how fast you learn with those.

Thanks for the quick reply… Don’t worry about me checking out the tutorials, been doing nothing but that.

But it seems that I’ve done the correct thing, just stuffing everything into the VST folder (including the effects).

But Renoise just still insists on not showing the DSPs in the “Track DSP” field. Everything else works fine, from actual VSPs to samples.

You mean that they are not listed?

Right on!

Actually if you selected the right plugin-directory from Preferences, then at the next start-up Renoise should find the plugins. But you can try hitting the “Rescan” button in the Preferences at the Plugins page.

But maybe if it’s Mac-related someone else can help because I’m not familiar with it.

Aight, thanks for the help I guess… Guess I have to try fiddling around with it a bit more, just to damn high right now, I’ll look at it tomorrow.

Anyways, thanks for the help dude. :)

Still doesn’t work, I’ve upped some screenies so you can see my situation better with ya own eyes. :)

This is my VST folder, see anything wrong…? I just put every file in there…

This pic shows how none of the DSPs are listed in Renoise:

Here a pic that shows that the VSTs are listed in Renoise:

Your effects type are shown as “Unix-Arkiv”, are you sure that they aren’t unpacked to the level they should be unpacked? It seems to me you still have to “execute” these archives to unpack them first. (quickly browsing, unix archive seem like a sort or self-installer)

All the other visible plugins say “.vst”

As far as I know, they aren’t any kind of packages in the normal zip/rar kind of format… Tried unpacking them with strange results.

But even normal DSPs (and not VSTs meant that they aren’t synthesisers or such) should have the .vst extension?

From the wiki: http://www.renoise.com/wiki/Free_VSTs

There is much confusion when it comes to Macintosh VST/VSTi due to the history of the platform.

Up until 2006 all Macintosh were built using PowerPC processors. If you have a G4 or G5 then you have a PowerPC. Nowadays, all Macintosh computers are built using Intel x86 processors.

A lot of old Plug-ins were made before 2006 and never updated. These plug-ins are known as PowerPC specific. These old plug-ins will only work on a G4 or a G5. They will not work on newer Intel Macs.

Universal binary Plug-ins are compiled in a special way which allow them to operate on both PowerPC and Intel Macs. The symbol used to indicate this feature is the Yin-Yang. These types of plug-ins work on all Macs.

As PowerPC dies out, Macintosh Plug-ins are expected to become Intel Only. These newer Plug-ins will not work on PowerPC machines.

Looks to me that you are trying to load old PPC plugins on a new Mac. From the screenshot, some VST are working, some are not. This is usually the reason.

Looks like a very reasonable explanation… Though, by looking at the site from where I’ve downloaded the DSPs (http://bram.smartelectronix.com/plugins.php?id=7), it should be OS X compatible, eh?

Do you know any (free) DSP plugin which should 100% for sure work on OS X, that I could maybe try out your theory with?

OSX was no Intel platform from day one.
SupaPhaser was originally Windows, the ported variant was done by Apulsoft http://www.apulsoft.ch/freeports/
When i scout for messages and newsposts about these plugs, they date back to 2004 while the first Intel Macs got introduced somewhere around 2005 / 2006?

I doubt Apulsoft neither SmartElectronix really keeps updating these plugs at all.
If you want clarity about if a plugin is Mac Intel compatible, you need to have a statement that these plugins are in fact a Universal binary. Just a statement that they are written for OSX is not a guarantee.

It sucks big time, but there is hardly something to do against it.

But you won’t need VST-s anyway so much 'cause you have excellent native effects in Renoise… ;)

Alrighty, that gave me some clarity on the OS X platform… But before I accept defeat, what about the “Mac OSX Audio Unit Version (Universal Binary)”-version, which is a available from the site before mentioned site by me?

And a little side note: Sure the native effects are great, they surely keep me entertained. :D It’s just the concept of not being able to use what DSPs I want to that screws me up!

But is anyone able to provide a link for a 100% Intel Mac OSX compatible DSP, so that I can troubleshoot Renoise? Just to make sure that I’m using shitty VSTs, not a shitty sequencer. ;)

Wait, I don’t understand your problem. The screenshot shows two VST. Are you saying you have none? Or are missing some? Very confusing…

OS X has been around since 2000. I ran OS X on a G4 and a G5 up until a few months ago. OS X does not mean Intel.

The MDA plugins work. Use these to test: http://sourceforge.net/projects/mda-vst/

Step 1) Did you enable VST in the Renoise preferences? AU are enabled by default, VST is not. Did you turn it on? Renoise -> Preferences -> Plug/Misc -> Makes sure you have checkmarks next to the two VST Plugins entries.

Step 2) In the same Preferences pane, are the paths to the VST folders correct? There are two paths. Do at least one of them lead to your VST?

Step 3) Do some VST work and others don’t? Or what? Please be more clear in your description.

Alrighty, I understand it gets a bit confusing now, so I’ll try to break it down. The problem is that my VSTs (meant the synthezisers and other instruments) do work, but the DSPs don’t.

What I’m trying to show with the pics is that Renoise does list the VSTs (Cheesemachine & Chip32), but not the effects/DSPs (Crazy Ivan, Supaphaser).

Comprende? :)

If you can grab your hands on a working Demo version of Cubase, you might be able to use the VST bridge and check out if those specific plugs show up in Cubase… if they do, they are probably PPC, if they don’t you really have one more step to go that you missed somewhere.
I notice quite some difference between the visual plugins in Renoise and the none visual plugins:The lacking .VST extension of those that you can’t see.

Hey guys, I just tried out the MDA plug-ins - and guess what, they work (also the effects/DSPs)! :D

I think the problem really centered about the Intel-thing as you said, so it’s probably just me who has to suck it up.

Anyway, really, really many thanks for all you peoples time and patience!