[Solved] Windows: Ni Massive Vst Doesn'T Work (Randomly Crashes)

Since 2.7, Massive hasn’t really worked at all. It keeps crashing all over the place. No problems existed under 2.6. Things that cause it to crash:

  1. Opening the external editor from a saved song, crashes Renoise instantly.
  2. Changing/loading a preset, same thing.
  3. Crashes randomly while playing song, even if the track is muted/off.
  4. Sometimes, though a lot less frequently, even when the song is stopped.

Sometimes after crashing windows says Renoise was closed because of Data Execution Prevenation, not very commong though. Oh and btw it doesn’t crash as in Renoise politely informing you there has been a fatal error and backing up a song etc, but rather just as in “Renoise has stopped working”, example below. I don’t think there’s a log file created because of it crashing this way. I’ve tried also changing every possible setting in the preferences but it doesn’t help at all.

Has anyone experienced such problems?

Use massive on pretty much every tune i make and had no probs so far .

Might be worth popping up your log file.

Are you maybe still running Renoise 2.7 B1? See http://www.renoise.com/board/index.php?/topic/29276-●►-27-beta-2-released/ for more info about such plugin crashes in B1 please.

Isn’t it created only when renoise sort of “prevents” the crashing and terminates itself? If not, I’ll gladly supply it.

No the same problem persists in every beta so far, currently using the latest, b4.

If Renoise is not able to catch such bugs/crashes, then somethings terribly wrong and unfortunately we also can’t find out more about the problem. Have you already tried reinstalling the plugins? NI plugs also tend to crash after a while, when their data bases got broken: See for example http://www.biggie.co.nz/discussion/native_instruments_massive_amp_abletoncubaselogic_cras how to fix such issues

Re-installing didn’t work, but I noticed there was an update. I installed it and now it seems to be working fine. I don’t understand how it suddenly stopped working when moving from 2.6 to 2.7 though. Thanks for the help.

Well, probably the update also repaired the databases. This is the number one problem with NI plugins, and simply tends to happen after a while for many people. I don’t think this has anything to do with Renoise 2.7…

Anyway, glad it’s working again.

was just about to ask if you had updated massive to latest version.glad you got it working :D

its a known problem.
you can workaround by delete the file NIMassiveDataBase_ul in user->user->appdata->local->native instruments->massive

and rebuild the DB in massive.

btw: do you’ve installed 64bit and 32bit version?

EDIT: blub already linked. sry