Some things I noticed while trying rns3 beta.

Hi there! Renoise3 looks great! Some problems I noticed:

  • in the instrument editor: It would be cool to have the order of modulation and effects interchangeable. E.g. for things like dubstep “wobble bass”, using an effect like distortion first and applying modulation after that would be perfect.
  • I can’t find the “#Line-In” device. I find this to be one of the essential meta devices. I hope it has vanished from the device list only by accident.
  • renoise3 beta seems to confuse script folders. after running beta3, 2.8.1 started on the same machine shows several messages like this one on startup:
    ‘/home/johannesk/.renoise/V2.8.1/Scripts/Tools/cas-renoise-tools/nl.jeweett.MidiSkip.xrnx/’ was written for a more recent version of Renoise.
    Current script API version is ‘3’ but the tool requires API version ‘4’.
  • i was doing something in the instrument editor, i think i clicked in the waveform view when rns3 crashed.
  • loading the backup file generated in the previous crash crashes renoise3 for me: see this file (file too big to attach).
  • “select instrument under cursor” seems to always be activated, even if it is turned off.
  • don’t know whether it is a bug or just a non-feature: the doofer doesn’t let me drop #send devices into it. i think it should, it would be extremely useful.
  • drag&dropping an LFO into a doofer crashes.
  • Not sure if this is a new one or was always like this: Apparently it isn’t possible to map Pitch Bend MIDI events in Renoise? This would be most useful. I just hacked a korg foot controller to send out MIDI messages, and I’m using pitch bend because it has 14-bit resolution, unlike CC messages which have only 7 bit. (And yes, other apps recognize the pitch bend correctly, so the problem is not in my hardware. The Midi-In-Light in Renoise lights up but it doesn’t recognize the Pitch Wheel event. Tried generating the Pitch Wheel event with software too. Same thing.)

Sorry if any of them have been reported. I didn’t read the whole forum.

Testing on ubuntu 13.10 64-bit using the 64-bit version of Renoise.

edit: add link to file that crashes renoise on load

Reading this it sounds like you actually need Renoise create a fresh install of the preferences folder (rename the preferences folder for 2.8.1, remove the one for 3.0.0, then restart Renoise)
2.8 Scripts that Renoise cannot convert and remain API 3 should be automatically disabled unless you reactivated the script yourself afterwards. If people manually decide to force API 3.0 scripts being enabled, there will always be a risk that the script does more damage than desired (worst case crashing)

I don’t see any attachment, but does it still happen with a fresh reinitialization of Renoise?

You don’t understand. Renoise3 not only loads and converts the scripts from the older version, apparently it also writes the autoconverted scripts to the script folder of the previous non-beta version I had installed, 2.8.1. When I start the old version after that, I see the above error messages.

I didn’t install the rns3 beta, I just ran it from where I extracted the archive. Maybe that helps with reproducing the problem.

I posted the file on dropbox and inserted the link in the first post.

I tried renaming my ~/.renoise folder and starting rns3. After doing this, it looks like this:

This behaviour is still the same obviously

This still persists

This still happens

After renaming ~/.renoise, I can’t reproduce this any more. Is it possible for a script to override this behaviour?

This still persists

After renaming ~/.renoise, I can’t reproduce this any more. I’m not sure whether this was caused by a script, or by something else in the song I was editing at the time.

This still persists

I have no clue myself here. Preference folders are dedicated to a Renoise version, Newer versions should not touch any older version archives.

Let’s clear up a few things and clean out your list…

It’s called #Line input now

That is by design, doofers should be self containable so send devices are out of the question, there are even intentions to leave out other kinds of meta devices which are instrument specific (instr. automation, midi control and macro control)

No it never was so, pitchbend is not a Midi CC signal.
It would indeed be nice if it would be mappable.

It is a nice suggestion, whether this is easy to accomplish is a different kind of thing simply because you want to modulate a processed signal.

I suspected these would be gone with a clean slate…

Which leaves us to just one serious problem left:

I guess this is up to the devs to see if they can reproduce…
I’m going to create a separate bug report for this so it doesn’t remain unattended.