Some Track/Group commands are ignored or warped when an instrument uses a phrase (SOLVED: Latency set too high)

Renoise 64Bit - V3.3.1 (Built: Jan 11 2021) MacOS Big Sur

Hi all!

I’m not sure this is intended behaviour, but I have noticed that using track/group commands is sometimes… weird when phrases are in play. (See the attached xrns for a detailed sample). For example:

  • I expect C0X to cut the volume to 0 after X ticks of a line, but… it seems to either be lagged or ignored in some cases
  • UXX / DXX seem to work consistently sometimes, but I’ve noticed GXX being ignored in some of my tracks.

I also haven’t managed to reproduce this on a small scale (still working on it), but I have noticed sometimes when I use phrases and track commands in tandem, the playback result can change after i save, restart renoise, and reload the file - specifically with GXX as a track command. When this happens I am not using any commands in the phrase itself, only on the track.

I’ll let you know if I can manage to reproduce the other behaviour on a smaller scale - it’s a little tricky since I have a hard time getting back to the state where it “worked” once

The attached xrns demonstrates laggy CXX behaviour in the presence of phrases. I am working on making a reproduction of the very strange GXX behaviour, but that one is a little tricky so it may take some time.

bug-repro.xrns (11.6 KB)

In the meanwhile, I suppose I should ask - is what I’m trying to do supported? Or is this a situation in which “don’t do that” might be the solution? I often use phrases to add/try out a quick octave or fifth doubling on an instrument, and it’s been really odd to see all my glides / stutters get “weird” when I reopen a file.


EDIT: Solved with the help of a second computer. In Preferences I had my latency set to max (as I was finished doing any MIDI recording and had moved on to mixing). Setting it to 15 or lower made it playback and render as expected.

Update - I wasn’t able to reproduce the “it’s different after I reload it” behaviour I described above, but here is a much better test file. My expectation would be that all four snippets in each marked section sound the same - but the first two seem to be struggling to apply smooth pitch bends and quick volume cuts, and sound quite different.


bug-repro.xrns (539.0 KB)

EDIT: In case this is a platform-specific thing, I’ve updated the above file to include a render of itself in a third instrument.

Had a listen and to be honest I’m unable to hear any difference between with and without phrases.
So decided to have a look, using a wav editor, and i can see a minor difference.


Time passed…

Just had a listen to the latest version with the render, and noticed something else;
our renders look very very different… upon further inspection, i’m seeing that the
render you provided is 48k although the samples are 44.1k.

Capture2 Capture4

Below is your module but with my render in it as well:
bug-repro4.xrns (1.2 MB)

Afraid these are merely observations, although i do hope this helps some.

Thanks for the tip - knowing it was likely an issue with my machine led me pretty much straight to the solution (see the edit in OP). Though it is a bit concerning that a too-high latency setting could mess with these commands so much - is there code that counts how many buffers have passed perhaps?

This also neatly explains the “I opened it up later (with different renoise settings) and it performed differently” behaviour.

Anyways, I’m happy to have this functionality back, and I’ll know what to do next time. Thanks for the help.